summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-17 03:01:50 +0100
committerSam James <sam@gentoo.org>2022-09-17 03:01:50 +0100
commitccb0b9eb86adc6437d5d522feeb1fa42c703b2b5 (patch)
tree3f11994b5a2324c69879c3cf339cd7d0d232070a
parenttoolchain.eclass: fix building Clang on pure LLVM profiles (diff)
downloadgentoo-ccb0b9eb.tar.gz
gentoo-ccb0b9eb.tar.bz2
gentoo-ccb0b9eb.zip
sys-process/lsof: add 4.96.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-process/lsof/Manifest1
-rw-r--r--sys-process/lsof/lsof-4.96.3.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index b1aaf692109b..96aefc575279 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1 +1,2 @@
DIST lsof-4.95.0.tar.gz 1343380 BLAKE2B ffb0a656463f8f0e84ddcba36d78a94a8b4b883f0ff043c3821b3236274fb11e04b8c82f84f4e67ab922f021769c2711c1e97716aef3190d640fc321110521a3 SHA512 09c5c4b0ea0530e23b98b96df8485f37c2594028b604097a816aee216a8b1a7bc887071e8727cbaf3c765d0992314a5aa49723572cfe926f88806be18a6b8aef
+DIST lsof-4.96.3.tar.gz 1342843 BLAKE2B 79e276d0db5138c356cc8bfa32e6f991ce8860644eb5d02f49ba04ce08076232f0fb8b10e143ee135205de5c64bd053d7bf021e48d666b65ffc01c0a47b76116 SHA512 ad17a73590ffb154a13b8b5de8ada738ce343fcc833012b2a5e9b3bda587785b09ae8bf090a99fba8e84b788c2a6d61eaa7359f939bfa68d2423e604801e2a98
diff --git a/sys-process/lsof/lsof-4.96.3.ebuild b/sys-process/lsof/lsof-4.96.3.ebuild
new file mode 100644
index 000000000000..02ae293dff8e
--- /dev/null
+++ b/sys-process/lsof/lsof-4.96.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples ipv6 rpc selinux"
+
+RDEPEND="rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/groff
+ rpc? ( virtual/pkgconfig )"
+
+# Needs fixing first
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.85-cross.patch # bug #432120
+)
+
+src_prepare() {
+ default
+
+ # Fix POSIX compliance with `echo`
+ sed -i \
+ -e 's:echo -n:printf:' \
+ AFSConfig Configure Customize Inventory tests/CkTestDB || die
+ # Convert `test -r header.h` into a compile test.
+ # Make sure we convert `test ... -a ...` into two `test` commands
+ # so we can then convert both over into a compile test. #601432
+ sed -i -E \
+ -e '/if test .* -a /s: -a : \&\& test :g' \
+ -e '/test -r/s:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:g' \
+ -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
+ Configure || die
+
+ # "create" man-page (bug #689462)
+ # inspired by shipped "makeman" ksh script
+ soelim < Lsof.8 > lsof.8 || die
+}
+
+target() {
+ case ${CHOST} in
+ *-darwin*) echo darwin ;;
+ *-freebsd*) echo freebsd ;;
+ *-solaris*) echo solaris ;;
+ *-aix*) echo aixgcc ;;
+ *) echo linux ;;
+ esac
+}
+
+src_configure() {
+ append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
+ append-cppflags $(usex ipv6 -{D,U}HASIPv6)
+
+ [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # make sys/proc_info.h available in ${T} because of LSOF_INCLUDE
+ # dummy location -- Darwin needs this for a Configure check to
+ # succeed
+ if [[ -e /usr/include/sys/proc_info.h ]] ; then
+ mkdir -p "${T}"/sys || die
+ ( cd "${T}"/sys && ln -s /usr/include/sys/proc_info.h ) || die
+ fi
+ fi
+
+ export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
+ $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
+
+ # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
+ # around in it and mix /usr/include paths with cross-compile/etc.
+ touch .neverInv
+ LINUX_HASSELINUX=$(usex selinux y n) \
+ LSOF_INCLUDE=${T} \
+ LSOF_CC=$(tc-getCC) \
+ LSOF_AR="$(tc-getAR) rc" \
+ LSOF_RANLIB=$(tc-getRANLIB) \
+ LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
+ ./Configure -n $(target) || die
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+src_install() {
+ dobin lsof
+
+ if use examples ; then
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ fi
+
+ doman lsof.8
+ dodoc 00*
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ elif [[ ${CHOST} == *-aix* ]] ; then
+ einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
+ fi
+}