summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 21:59:13 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 21:59:13 +0200
commitccbb0f907ba692f0b3806b5f8ab372ecbdac896b (patch)
tree8a8ce46bdb5062156f804b7b665eae23216582ca
parentgames-puzzle/anagramarama: [QA] Pass CC to build system (diff)
downloadgentoo-ccbb0f90.tar.gz
gentoo-ccbb0f90.tar.bz2
gentoo-ccbb0f90.zip
games-util/loki_patch: [QA] Use AM_PROG_AR
Closes: https://bugs.gentoo.org/724698 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--games-util/loki_patch/files/loki_patch-20091105-build.patch23
-rw-r--r--games-util/loki_patch/files/loki_patch-20091105-patchdata.patch4
-rw-r--r--games-util/loki_patch/loki_patch-20091105.ebuild42
3 files changed, 39 insertions, 30 deletions
diff --git a/games-util/loki_patch/files/loki_patch-20091105-build.patch b/games-util/loki_patch/files/loki_patch-20091105-build.patch
index 8e2b5bbf1557..e17007e57a75 100644
--- a/games-util/loki_patch/files/loki_patch-20091105-build.patch
+++ b/games-util/loki_patch/files/loki_patch-20091105-build.patch
@@ -1,5 +1,5 @@
---- loki_patch/configure.in
-+++ loki_patch/configure.in
+--- a/loki_patch/configure.in
++++ b/loki_patch/configure.in
@@ -1,4 +1,4 @@
-AC_INIT(README)
+AC_INIT(loki_patch, 1.0.2)
@@ -60,8 +60,8 @@
CFLAGS="$CFLAGS -I$SETUPDB"
AC_SUBST(SETUPDB)
---- loki_patch/loki_xdelta.c
-+++ loki_patch/loki_xdelta.c
+--- a/loki_patch/loki_xdelta.c
++++ b/loki_patch/loki_xdelta.c
@@ -49,7 +49,7 @@
#define LOKI_PATCH
@@ -71,8 +71,8 @@
static HandleFuncTable xd_handle_table;
---- loki_patch/Makefile.am
-+++ loki_patch/Makefile.am
+--- a/dev/null
++++ b/loki_patch/Makefile.am
@@ -0,0 +1,12 @@
+COMMONSRC = load_patch.c size_patch.c print_patch.c \
+ loki_xdelta.c mkdirhier.c log_output.c
@@ -86,8 +86,8 @@
+AM_CPPFLAGS = $(XDELTA_CFLAGS)
+
+LDADD = $(top_builddir)/../loki_setupdb/libsetupdb.a $(XDELTA_LIBS) $(XML_LIBS) -lz
---- loki_setupdb/configure.in
-+++ loki_setupdb/configure.in
+--- a/loki_setupdb/configure.in
++++ b/loki_setupdb/configure.in
@@ -1,4 +1,4 @@
-AC_INIT
+AC_INIT(setupdb, 1.6.5)
@@ -111,7 +111,8 @@
+AM_INIT_AUTOMAKE(foreign no-dependencies)
AC_PROG_CC
AC_PROG_MAKE_SET
- AC_PATH_PROGS(AR, [ar gar])
+-AC_PATH_PROGS(AR, [ar gar])
++AM_PROG_AR
+AC_PROG_RANLIB
AC_CHECK_HEADERS(unistd.h)
@@ -165,8 +166,8 @@
AC_ARG_WITH(vendor,
[ --with-vendor with specified vendor prefix [default=loki]],
---- loki_setupdb/Makefile.am
-+++ loki_setupdb/Makefile.am
+--- a/dev/null
++++ b/loki_setupdb/Makefile.am
@@ -0,0 +1,9 @@
+noinst_LIBRARIES = libsetupdb.a
+
diff --git a/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch b/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
index 74ec3dae7568..403c24ed79f9 100644
--- a/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
+++ b/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
@@ -1,5 +1,5 @@
---- loki_patch/load_patch.c
-+++ loki_patch/load_patch.c
+--- a/loki_patch/load_patch.c
++++ b/loki_patch/load_patch.c
@@ -8,7 +8,7 @@
#include "load_patch.h"
#include "log_output.h"
diff --git a/games-util/loki_patch/loki_patch-20091105.ebuild b/games-util/loki_patch/loki_patch-20091105.ebuild
index b3084027a98d..1fc2b57f633a 100644
--- a/games-util/loki_patch/loki_patch-20091105.ebuild
+++ b/games-util/loki_patch/loki_patch-20091105.ebuild
@@ -1,41 +1,49 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Loki Software binary patch tool"
HOMEPAGE="http://www.icculus.org/loki_setup/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
mirror://gentoo/loki_setupdb-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-util/xdelta:0
+RDEPEND="
+ dev-util/xdelta:0
dev-libs/libxml2
dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}
+S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-patchdata.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-patchdata.patch
- cd loki_setupdb
+ default
+
+ cd loki_setupdb || die
+ mv configure.{in,ac} || die
eautoreconf
- cd "${S}"/${PN}
+
+ cd "${S}"/${PN} || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- cd loki_setupdb
+ cd loki_setupdb || die
econf
- cd "${S}"/${PN}
+ cd "${S}"/${PN} || die
econf
}
@@ -45,7 +53,7 @@ src_compile() {
}
src_install() {
- cd ${PN}
+ cd ${PN} || die
dobin loki_patch make_patch
dodoc CHANGES NOTES README TODO
}