summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-10 17:25:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-10 17:36:54 +0100
commitccc92d925915e515d384313c5ee5f13d1efaebce (patch)
tree9d3da77e61b565418e6605d7555b846d16750f2e
parentpackage.mask: Last rite dev-python/{dparse,pipenv} (diff)
downloadgentoo-ccc92d925915e515d384313c5ee5f13d1efaebce.tar.gz
gentoo-ccc92d925915e515d384313c5ee5f13d1efaebce.tar.bz2
gentoo-ccc92d925915e515d384313c5ee5f13d1efaebce.zip
dev-python/pythonfinder: Remove old
Closes: https://bugs.gentoo.org/925699 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pythonfinder/Manifest2
-rw-r--r--dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch13
-rw-r--r--dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch38
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.5.ebuild29
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.6.ebuild40
5 files changed, 0 insertions, 122 deletions
diff --git a/dev-python/pythonfinder/Manifest b/dev-python/pythonfinder/Manifest
index a258f9eb1e78..ceaa7d12fb6d 100644
--- a/dev-python/pythonfinder/Manifest
+++ b/dev-python/pythonfinder/Manifest
@@ -1,3 +1 @@
-DIST pythonfinder-2.0.5.tar.gz 718776 BLAKE2B 32a49dbff143042554d5328b61b612e3bde7a870d53a229303b6bdd2c2ce76457bf6aadcdb215efa332407003c1319215292f3278a2808b669b5b7819af08902 SHA512 4d205c66d7ae36f4f2b8ddab9cce00f4efd5548a41d251470a515b88f8be2dcede75372b9301223822031ae663c6ccf77156531b0dd5d8972424f90641255c5b
-DIST pythonfinder-2.0.6.tar.gz 718821 BLAKE2B bc45c8ebffd4b8a21084c3b5f4d9cba71383613e6b25ec01ba53b0abf5d01cf78d1636b19c6c32f80eec401c56c25eedded793fabc46e2bbd389074a45ae14f5 SHA512 2aad884101d1a9fc1340fb63b11811aa7bd1c1f6d2945f9d133bb473099c7e11da21a4348ca742cae03a23fc8b12b85dcae4e9b3a2d29ec98530b6d8d2567d1c
DIST pythonfinder-2.1.0.tar.gz 717240 BLAKE2B 73e748c1c8d3b38270d9d73861c296eb96685f2bf1318344f7f6214b948381e464a90422451a49c32b4e6117c5a75ba8af0cffc75405a65e28c5f3e14f8c834a SHA512 ddba8fe6fbd986c48be941b1bd76f8ca1f11985cadbce55a51e1fd110c2a8bc99c7536c288f2e16d0204bd854ee46db1761c12bca336d74764e99ab424210555
diff --git a/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch b/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch
deleted file mode 100644
index ce1af3244fbd..000000000000
--- a/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
-index a8fb807..a933a91 100644
---- a/src/pythonfinder/models/path.py
-+++ b/src/pythonfinder/models/path.py
-@@ -19,7 +19,7 @@ from typing import (
- Union,
- )
-
--from cached_property import cached_property
-+from functools import cached_property
- from pydantic import Field, root_validator
-
- from ..environment import (
diff --git a/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch b/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
deleted file mode 100644
index 6b3840361bed..000000000000
--- a/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/pyproject.toml b/pyproject.toml
-index 73a3c85..27c9a7e 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -39 +39 @@ dependencies = [
-- "pydantic>=1.10.7,<2",
-+ "pydantic>=2",
-@@ -140 +140 @@ runtime-evaluated-base-classes = [
-- "pydantic.BaseModel",
-+ "pydantic.v1.BaseModel",
-diff --git a/src/pythonfinder/models/common.py b/src/pythonfinder/models/common.py
-index 4c439c9..0ef3d77 100644
---- a/src/pythonfinder/models/common.py
-+++ b/src/pythonfinder/models/common.py
-@@ -3 +3 @@ from __future__ import annotations
--from pydantic import BaseModel, Extra
-+from pydantic.v1 import BaseModel, Extra
-diff --git a/src/pythonfinder/models/mixins.py b/src/pythonfinder/models/mixins.py
-index 58ce99a..e68020f 100644
---- a/src/pythonfinder/models/mixins.py
-+++ b/src/pythonfinder/models/mixins.py
-@@ -15 +15 @@ from typing import (
--from pydantic import BaseModel, Field, validator
-+from pydantic.v1 import BaseModel, Field, validator
-diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
-index fe98054..beb88be 100644
---- a/src/pythonfinder/models/path.py
-+++ b/src/pythonfinder/models/path.py
-@@ -26 +26 @@ else:
--from pydantic import Field, root_validator
-+from pydantic.v1 import Field, root_validator
-diff --git a/src/pythonfinder/models/python.py b/src/pythonfinder/models/python.py
-index c5e0345..32c82a8 100644
---- a/src/pythonfinder/models/python.py
-+++ b/src/pythonfinder/models/python.py
-@@ -22 +22 @@ from packaging.version import Version
--from pydantic import Field, validator
-+from pydantic.v1 import Field, validator
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
deleted file mode 100644
index ff44faf9643c..000000000000
--- a/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
-HOMEPAGE="
- https://github.com/sarugaku/pythonfinder
- https://pypi.org/project/pythonfinder/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-PATCHES=(
- "${FILESDIR}/2.0.5-fix-import-cached-property.patch"
-)
-
-RDEPEND="
- <dev-python/pydantic-2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
deleted file mode 100644
index a7d99c9760e4..000000000000
--- a/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
-HOMEPAGE="
- https://github.com/sarugaku/pythonfinder/
- https://pypi.org/project/pythonfinder/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-RDEPEND="
- >=dev-python/pydantic-2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/click[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # based on the patch from Arch
- # https://gitlab.archlinux.org/archlinux/packaging/packages/python-pythonfinder/-/blob/main/python-pythonfinder-2.0.5-pydantic2.patch
- "${FILESDIR}"/pythonfinder-2.0.6-pydantic-2.patch
-)
-
-python_test() {
- epytest -o addopts=
-}