summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 16:17:05 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 16:17:05 +0100
commitcce4f7dd97738aa11023f07b8279b86112b1fb63 (patch)
treef87c578063c1b6b29e743e24477c94af3c876e68
parentdev-embedded/libftdi: Port to EAPI 7 (diff)
downloadgentoo-cce4f7dd.tar.gz
gentoo-cce4f7dd.tar.bz2
gentoo-cce4f7dd.zip
dev-embedded/libftdi: Disable static libs in 1.5 and 9999
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-embedded/libftdi/libftdi-1.5.ebuild16
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild12
2 files changed, 13 insertions, 15 deletions
diff --git a/dev-embedded/libftdi/libftdi-1.5.ebuild b/dev-embedded/libftdi/libftdi-1.5.ebuild
index d5d1fe185434..cd5cc4c3539f 100644
--- a/dev-embedded/libftdi/libftdi-1.5.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
@@ -21,15 +21,15 @@ S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="1"
-IUSE="cxx doc examples python static-libs test tools"
+IUSE="cxx doc examples python test tools"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
doc? ( app-doc/doxygen )
- python? ( dev-lang/swig )
-"
-RDEPEND="virtual/libusb:1
+ python? ( dev-lang/swig )"
+RDEPEND="
+ virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( ${PYTHON_DEPS} )
tools? (
@@ -40,9 +40,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/boost )
"
-PATCHES=(
- "${FILESDIR}/${P}-tests-no-cxx.patch"
-)
+PATCHES=( "${FILESDIR}"/${P}-tests-no-cxx.patch )
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -54,10 +52,10 @@ src_configure() {
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
-DPYTHON_BINDINGS=$(usex python)
- -DSTATICLIBS=$(usex static-libs)
-DBUILD_TESTS=$(usex test)
-DFTDI_EEPROM=$(usex tools)
-DCMAKE_SKIP_BUILD_RPATH=ON
+ -DSTATICLIBS=OFF
)
cmake_src_configure
}
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index ac06a98e9188..984ebde256da 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
@@ -21,15 +21,15 @@ S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="1"
-IUSE="cxx doc examples python static-libs test tools"
+IUSE="cxx doc examples python test tools"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
doc? ( app-doc/doxygen )
- python? ( dev-lang/swig )
-"
-RDEPEND="virtual/libusb:1
+ python? ( dev-lang/swig )"
+RDEPEND="
+ virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( ${PYTHON_DEPS} )
tools? (
@@ -50,10 +50,10 @@ src_configure() {
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
-DPYTHON_BINDINGS=$(usex python)
- -DSTATICLIBS=$(usex static-libs)
-DBUILD_TESTS=$(usex test)
-DFTDI_EEPROM=$(usex tools)
-DCMAKE_SKIP_BUILD_RPATH=ON
+ -DSTATICLIBS=OFF
)
cmake_src_configure
}