summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2021-08-05 09:24:25 -0400
committerRichard Freeman <rich0@gentoo.org>2021-08-05 09:24:25 -0400
commitccef85f77039a811824ed2d08b3318fa81561725 (patch)
tree3b82b4b5891335e71023416c7ab9453236c0e248
parentapp-backup/duplicity: bump (diff)
downloadgentoo-ccef85f7.tar.gz
gentoo-ccef85f7.tar.bz2
gentoo-ccef85f7.zip
app-backup/duplicity: clean old version with python compat issues
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Richard Freeman <rich0@gentoo.org>
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.17.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.17-fix-docs-cmd.patch28
3 files changed, 0 insertions, 80 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index ff231714ddca..91d6a0daf4f6 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,2 @@
-DIST duplicity-0.8.17.tar.gz 1351433 BLAKE2B 39c87c421bb8a4bf27e60c16b6dde559ed4468a1062f02623d8e37deb62e63101b6fb5524e5a991139d39422cab2803b89007bf1ca5819817ab3b53d5318b88c SHA512 6f9f6b45953d2bc7ed403d68bdc419f384e07f831c783af720f15f88b100f5becb3f83f65cfc715b02686c24d18c5ec8f80c27789d1ec01cdc8efefa7590c211
DIST duplicity-0.8.19.tar.gz 1372739 BLAKE2B 6a5a642597529eea37c7224cbfdd115db42c16f6391e553454f8f82cea86240bbd68a62513129496a1f978411fdeec50c3d918bb99b470fa1444fd77e7e6c9b7 SHA512 c1a1f5894f8b94ac61bd98270f138c58ef5a68f3624e7e88224b15539ca6e08874df9cebb36b10167d133b1af6a93b29e7bf4084c348b9cd7914ff24415be57c
DIST duplicity-0.8.20.tar.gz 1376671 BLAKE2B af3fd95b699cd9b3c6bbe259e0dd898fc058461efcb2d1d51c8c2d539df7e32fe70fb6af4b314cd6fce219345f23eb0ab342d0c7f28b05ec1ee4333c02d93415 SHA512 ac43473a18031fa33cee0b7a3dc6b33c830ba9d19a0129c065a226824af8aacf00230ae05bf2e0d7614ad4ce9724e40e9b8305114175af63d8a8a8642ffdce67
diff --git a/app-backup/duplicity/duplicity-0.8.17.ebuild b/app-backup/duplicity/duplicity-0.8.17.ebuild
deleted file mode 100644
index 8f7cf391d022..000000000000
--- a/app-backup/duplicity/duplicity-0.8.17.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-
-inherit distutils-r1
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="https://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="s3 test"
-
-CDEPEND="
- net-libs/librsync
- app-crypt/gnupg
- dev-python/fasteners[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- app-arch/par2cmdline
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-docs-cmd.patch"
-)
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- elog "Duplicity has many optional dependencies to support various backends."
- elog "Currently it's up to you to install them as necessary."
-}
diff --git a/app-backup/duplicity/files/duplicity-0.8.17-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.17-fix-docs-cmd.patch
deleted file mode 100644
index a0fce6b2c5d8..000000000000
--- a/app-backup/duplicity/files/duplicity-0.8.17-fix-docs-cmd.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- duplicity-0.8.17/setup.py 2020-11-24 19:32:40.089024404 -0500
-+++ duplicity-0.8.17/setup.py 2020-11-24 19:33:32.326309755 -0500
-@@ -93,17 +93,6 @@
- u'bin/rdiffdir.1'
- ]
- ),
-- (u'share/doc/duplicity-%s' % Version,
-- [
-- u'AUTHORS',
-- u'CHANGELOG.md',
-- u'COPYING',
-- u'README.md',
-- u'README-LOG.md',
-- u'README-REPO.md',
-- u'README-TESTING.md',
-- ],
-- ),
- ]
-
- if not os.environ.get(u'READTHEDOCS') == u'True':
-@@ -339,7 +328,6 @@
- ],
- test_suite=u"testing",
- cmdclass={
-- u"build_scripts": BuildScriptsCommand,
- u"install": InstallCommand,
- u"install_data": InstallDataCommand,
- u"sdist": SdistCommand,