summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 17:19:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 17:24:41 +0100
commitcd15ab208a6a551069ec014a264c65aa94c04562 (patch)
treeeb17b85cdbd8d80025c4324da37a62eb0b941b17
parentdev-python/recurring-ical-events: Bump to 2.1.3 (diff)
downloadgentoo-cd15ab208a6a551069ec014a264c65aa94c04562.tar.gz
gentoo-cd15ab208a6a551069ec014a264c65aa94c04562.tar.bz2
gentoo-cd15ab208a6a551069ec014a264c65aa94c04562.zip
dev-python/x-wr-timezone: Bump to 0.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/x-wr-timezone/Manifest1
-rw-r--r--dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/x-wr-timezone/Manifest b/dev-python/x-wr-timezone/Manifest
index 39377130f7b4..f5f31581ea3f 100644
--- a/dev-python/x-wr-timezone/Manifest
+++ b/dev-python/x-wr-timezone/Manifest
@@ -1 +1,2 @@
DIST x-wr-timezone-0.0.6.gh.tar.gz 21989 BLAKE2B 0b6c1ba79d32d37a786a3dff73ee5f8317e6426c441a9ff7880d2c0c2fc9e535e29977f094a4bb4b95477f7a1586c1a1800abcede76ffe474879f63e38b00521 SHA512 62b7ef9d904a46711b1a29866b92327543c38cdba2a488769345210599eef2899310cad09bf4da4debe6bc7e78e3370aaf271a663250312d859f5c98850cb553
+DIST x-wr-timezone-0.0.7.gh.tar.gz 21988 BLAKE2B fa8ebf44de060b8e716dda0970dbf881f635d1fbaffb1f6fcfe1f847d4b3b765dbd89141a8aa96393cd205bdfd7e913f9405e22fdb22bbbe148ef0c0a75a291f SHA512 6d37de592741a8786855a1f6c8b61165b3267869dcd86e0b9fe56de31f326ee2f7206ab35c45c21713d4cc808d1b14934d6b5b9daac90791d13b0363af5b5cbf
diff --git a/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild b/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild
new file mode 100644
index 000000000000..bdc5e6f792b8
--- /dev/null
+++ b/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
+HOMEPAGE="
+ https://github.com/niccokunzmann/x-wr-timezone/
+ https://pypi.org/project/x-wr-timezone/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/icalendar-5.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)