summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-14 13:26:36 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-14 13:27:54 -0400
commitcd2709872eb379dcb3442b1a34409f6c82e54a1c (patch)
tree869ee877288cd6112834dd3339b1fd02fd0dda24
parentdev-libs/libvterm: Version bump to 0.3.2 (diff)
downloadgentoo-cd2709872eb379dcb3442b1a34409f6c82e54a1c.tar.gz
gentoo-cd2709872eb379dcb3442b1a34409f6c82e54a1c.tar.bz2
gentoo-cd2709872eb379dcb3442b1a34409f6c82e54a1c.zip
x11-misc/xkeyboard-config: Version bump to 2.39
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.39.ebuild42
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild4
3 files changed, 45 insertions, 2 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 3496b76a2900..be72564a89e8 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.38.tar.xz 884988 BLAKE2B 058543eb04917c785bbb02b5a11a2492c4ad3e1910e764f476e04fd2405e4c158d7e4942da00693efc683a39dd9fe11e55003c1c9ce10cc802744e98ebcd269d SHA512 20848a5a10cfa58265518add796fd97ddd2e39e7a87b18170cd9ebc3ec87268e92641f2cd8aaed1ed80cdbe3801b65a8a916321ffc20a419511b3d2a85b0dd2a
+DIST xkeyboard-config-2.39.tar.xz 896112 BLAKE2B d1ef598a0c1993518b01e73c319147ea1f3e55e1c8040762b9e95636c89d9b719322f3f2a1a87bffc545928b2912ead37f336182ba69d692893521322f170e21 SHA512 4690a0291c1f8c2c53b84984221a60a935c9b7cfc8ae20a8740403571f3704dedf06e5755b45775a15a5df21ebd2acac3ff785ff19f54d792ae359c4c6d60756
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.39.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.39.ebuild
new file mode 100644
index 000000000000..525a1106e280
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.39.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
index 8e3848465906..525a1106e280 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit meson python-any-r1
DESCRIPTION="X keyboard configuration database"