summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-31 22:04:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-31 22:09:41 +0200
commitcd3af2b5be8163b13c75afe0f838151935e3a3c8 (patch)
tree8c72baaa8f1338b81871f2d88fe772c8bb651355
parentsys-libs/libcap-ng: enable py3.10 (diff)
downloadgentoo-cd3af2b5be8163b13c75afe0f838151935e3a3c8.tar.gz
gentoo-cd3af2b5be8163b13c75afe0f838151935e3a3c8.tar.bz2
gentoo-cd3af2b5be8163b13c75afe0f838151935e3a3c8.zip
dev-python/subunit: drop 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/subunit/Manifest1
-rw-r--r--dev-python/subunit/subunit-1.4.0.ebuild103
2 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
index e59f6c68e1f4..eecdb73522a1 100644
--- a/dev-python/subunit/Manifest
+++ b/dev-python/subunit/Manifest
@@ -1,2 +1 @@
-DIST subunit-1.4.0.tar.gz 488022 BLAKE2B 4c3a714d02eeed9420074c4e032778a69b716a5cad0079193533e9bc8c0f4576d70b165eb413203ce8a916ac28466e9f5a113d4a7746019d7d09409df9860bae SHA512 5d2e3cb96c09067ef4595c86648f13330c810b19e39c0b35bc9546c57bee957ddcf5cad7b8e3f92bda9b54dcdbf175863e2f6ba94020f880230459be7afdbbcf
DIST subunit-1.4.0_p20210729.tar.gz 112644 BLAKE2B 56e785c029f3f2896d0ed3d8005c37403e6aa32d05b653db0e3b679d2157820558e578b53133f4f79404a660f37a710aeeec03ff941fd7cd0819020a0d474515 SHA512 90b1ad071fb5246a7446a4c999142566b9d96c39838905e9020b80f2f0aba0b86dd5185bbd25ff7fc65f69ae68e1e53dfde5b2de05755aa97db9248c6faaa9d7
diff --git a/dev-python/subunit/subunit-1.4.0.ebuild b/dev-python/subunit/subunit-1.4.0.ebuild
deleted file mode 100644
index f95225ac17d0..000000000000
--- a/dev-python/subunit/subunit-1.4.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
-
-inherit distutils-r1 multilib-minimal autotools
-
-DESCRIPTION="A streaming protocol for test results"
-HOMEPAGE="https://launchpad.net/subunit https://pypi.org/project/python-subunit/"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]
- dev-lang/perl:="
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
- >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
- >=virtual/pkgconfig-0-r1
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/subunit-1.4.0-werror.patch"
-)
-
-src_prepare() {
- sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
-
- # Install perl modules in vendor_perl, bug 534654.
- export INSTALLDIRS=vendor
-
- # fails on py3.6
- sed -i -e 's:test_add_tag:_&:' \
- python/subunit/tests/test_subunit_tags.py || die
-
- # eliminate unittest2
- sed -i -e 's:unittest2 as ::' \
- python/subunit/tests/test_test_protocol.py || die
-
- distutils-r1_src_prepare
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && distutils-r1_src_compile
-}
-
-python_test() {
- local -x PATH="${PWD}/shell/share:${PATH}"
- local -x PYTHONPATH=python
- # Following tests are known to fail in py2.7 & pypy. They pass under py3.
- # DO NOT re-file
- # test_add_error test_add_error_details test_add_expected_failure
- # test_add_expected_failure_details test_add_failure test_add_failure
- # https://bugs.launchpad.net/subunit/+bug/1436686
-
- "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
-}
-
-multilib_src_test() {
- multilib_is_native_abi && distutils-r1_src_test
-}
-
-multilib_src_install() {
- local targets=(
- install-include_subunitHEADERS
- install-pcdataDATA
- install-exec-local
- install-libLTLIBRARIES
- )
- emake DESTDIR="${D}" "${targets[@]}"
-
- multilib_is_native_abi && distutils-r1_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${D}" -name '*.la' -delete || die
-}