summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-06 19:35:34 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-06 22:18:01 +0100
commitcd3e0eb0f9741f74670bd4d566539af06e875728 (patch)
tree544d5290687094032164a2d6277b364af0eefb73
parentsys-libs/libapparmor: Use DISTUTILS_DEPS (diff)
downloadgentoo-cd3e0eb0f9741f74670bd4d566539af06e875728.tar.gz
gentoo-cd3e0eb0f9741f74670bd4d566539af06e875728.tar.bz2
gentoo-cd3e0eb0f9741f74670bd4d566539af06e875728.zip
sys-libs/libseccomp: Use DISTUTILS_DEPS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild16
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild16
2 files changed, 22 insertions, 10 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
index d935008bb87f..db6a08dfb2a6 100644
--- a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
+++ b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
@@ -27,17 +27,23 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="experimental-loong python static-libs test"
RESTRICT="!test? ( test )"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# We need newer kernel headers; we don't keep strict control of the exact
# version here, just be safe and pull in the latest stable ones. bug #551248
-DEPEND=">=sys-kernel/linux-headers-5.15
- python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ >=sys-kernel/linux-headers-5.15
+ python? ( ${PYTHON_DEPS} )
+"
RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}
+BDEPEND="
+ ${DEPEND}
dev-util/gperf
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ ${DISTUTILS_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+"
PATCHES=(
"${FILESDIR}"/libseccomp-python-shared.patch
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
index 1969eef9f5ea..45cf592639a0 100644
--- a/sys-libs/libseccomp/libseccomp-9999.ebuild
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -26,17 +26,23 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="python static-libs test"
RESTRICT="!test? ( test )"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# We need newer kernel headers; we don't keep strict control of the exact
# version here, just be safe and pull in the latest stable ones. bug #551248
-DEPEND=">=sys-kernel/linux-headers-5.15
- python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ >=sys-kernel/linux-headers-5.15
+ python? ( ${PYTHON_DEPS} )
+"
RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}
+BDEPEND="
+ ${DEPEND}
dev-util/gperf
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ ${DISTUTILS_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+"
PATCHES=(
"${FILESDIR}"/libseccomp-2.6.0-python-shared.patch