summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-26 08:00:07 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:38 +0000
commitcd4588a3a8db432b6b8312d5675c1de297803334 (patch)
treef6664a124f6c4cff92b03a485d4f868e543f979c
parentsci-libs/coinor-flopcpp: add github remote-id (diff)
downloadgentoo-cd4588a3.tar.gz
gentoo-cd4588a3.tar.bz2
gentoo-cd4588a3.zip
sci-libs/coinor-flopcpp: bump to 1.2.5, ported to EAPI 7
Has reworked old workarounds and reviewed deps. USE=examples removed, now installed unconditionally (small files). USE=static-libs removed. Bump fixed previous build issues (bug #664540). Closes: https://bugs.gentoo.org/664540 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/coinor-flopcpp/Manifest1
-rw-r--r--sci-libs/coinor-flopcpp/coinor-flopcpp-1.2.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/coinor-flopcpp/Manifest b/sci-libs/coinor-flopcpp/Manifest
index d49afb42cd77..01cedc97e66a 100644
--- a/sci-libs/coinor-flopcpp/Manifest
+++ b/sci-libs/coinor-flopcpp/Manifest
@@ -1 +1,2 @@
DIST FlopC++-1.1.7.tgz 6631744 BLAKE2B a6666480b800819b2132c6375483c35542bfd177201cd6cdd9b6ab36c42ef5d66308bf049ba0e7d7891cec32656e9fc0e4684c04e4628b5de3758be277d55142 SHA512 40f59cb34f61f6ff1759a90909a81d724a562ee9dbfe91628ad8df1b8049afff254ceeb56f1e68a48d035e6d3a140744b8ebd8815ee39c9f01e17860c904942d
+DIST coinor-flopcpp-1.2.5.tar.gz 615614 BLAKE2B ff356ca41ed7639c2916c55f04ae561abfaeef041bd04730d0ca774cb6506f023c1c31e3463d93a34f41d534fb189cb794a20daa155dbdf43303c22272a6c986 SHA512 45d9e5b976d2fb26be34d5e201a7aed24ec8717472902f4848c353a12f17488903b00e6675e2a3e90ac0da58581afb6fd48d3869b8fd7ce962cef98622755d7d
diff --git a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.2.5.ebuild b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.2.5.ebuild
new file mode 100644
index 000000000000..9139e3120b48
--- /dev/null
+++ b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.2.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="COIN-OR algebraic modeling language for linear optimization"
+HOMEPAGE="https://projects.coin-or.org/FlopC++/"
+SRC_URI="https://github.com/coin-or/FlopCpp/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FlopCpp-releases-${PV}/FlopCpp"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+src_prepare() {
+ default
+ # Prevent unneeded call to pkg-config that needs ${ED}'s in path.
+ sed -i '/--libs.*addlibs.txt/d' Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_with doc dot)
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc '')
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ default
+ dodoc -r examples
+ use doc && dodoc -r doxydoc/html
+
+ # Duplicate or irrelevant files.
+ rm -r "${ED}"/usr/share/coin/doc || die
+ find "${ED}" -name '*.la' -delete || die
+}