summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 20:02:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 20:06:53 +0100
commitcd47e2354c83f8c0c54fce69d6ec0a329620d9d3 (patch)
tree192c5bce374cee6ab00f34ff1d84dbfcf3fb257a
parentdev-python/python-dateutil: Bump to 2.9.0 (diff)
downloadgentoo-cd47e2354c83f8c0c54fce69d6ec0a329620d9d3.tar.gz
gentoo-cd47e2354c83f8c0c54fce69d6ec0a329620d9d3.tar.bz2
gentoo-cd47e2354c83f8c0c54fce69d6ec0a329620d9d3.zip
dev-python/mkdocs-static-i18n: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mkdocs-static-i18n/Manifest1
-rw-r--r--dev-python/mkdocs-static-i18n/mkdocs-static-i18n-1.2.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mkdocs-static-i18n/Manifest b/dev-python/mkdocs-static-i18n/Manifest
index da6fd44e94c4..91cc04515db8 100644
--- a/dev-python/mkdocs-static-i18n/Manifest
+++ b/dev-python/mkdocs-static-i18n/Manifest
@@ -1 +1,2 @@
DIST mkdocs_static_i18n-1.2.0.tar.gz 1368013 BLAKE2B b983be467a6afab2e40e9452f625fa1771eb640142fc3e9ce2c1df3d93442e91a1f99ef17ba06ff4045b2c9a1c049f63ab99971416875c592ad15e581710a519 SHA512 a5737faf85adf76d8dd60fa9fd21f454177318508fcb9a74f63208ade7013975c5bb23646261e579b1c1617e214568e07c788c6ba8af9fe2ee3877308bcff6c7
+DIST mkdocs_static_i18n-1.2.2.tar.gz 1370000 BLAKE2B 2be26c971ad28a306b6d34adb4c8359954f4a7333f031f1939c08a470388004f9ac825da3c5b4e6a88e5dd41dfb12ac972938bf39b80c91ef16b760ea3c6c46a SHA512 7a356590b306c92d4cd664c90538110bf613220930c17a5285aeb4f9ad092ea9b93efd2390beed6609f176aa26ab4f51be60c89e2d2da19a1d78ac2603fe891b
diff --git a/dev-python/mkdocs-static-i18n/mkdocs-static-i18n-1.2.2.ebuild b/dev-python/mkdocs-static-i18n/mkdocs-static-i18n-1.2.2.ebuild
new file mode 100644
index 000000000000..ebaafc9439a1
--- /dev/null
+++ b/dev-python/mkdocs-static-i18n/mkdocs-static-i18n-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="hatchling"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MkDocs i18n plugin using static translation markdown files"
+HOMEPAGE="
+ https://github.com/ultrabug/mkdocs-static-i18n
+ https://pypi.org/project/mkdocs-static-i18n/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/mkdocs-1.5.2[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ !!dev-python/mkdocs-i18n
+ )
+"
+
+distutils_enable_tests pytest