summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 09:08:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 09:21:22 +0200
commitcd4a4ec7dba494739e61e15f9dfd41a45b8ebb55 (patch)
treec8e24e8e4804288f688d764e2a9ffba41c6043d9
parentdev-python/zope-event: Bump to 4.5.0 (diff)
downloadgentoo-cd4a4ec7dba494739e61e15f9dfd41a45b8ebb55.tar.gz
gentoo-cd4a4ec7dba494739e61e15f9dfd41a45b8ebb55.tar.bz2
gentoo-cd4a4ec7dba494739e61e15f9dfd41a45b8ebb55.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.11.2.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index c102b84d3279..d702701e0eed 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,4 +1,3 @@
-DIST pytest-mock-1.11.2.tar.gz 22825 BLAKE2B d6843d1cb1afc0d5a242103ec4900d56418198b84fa037faf4b6841d7fbfd388273a819a26bfe051e6030690105e74211a27d2b864448598962b3e03788958fa SHA512 6dc927ce35001d088bddd9d79e024141b9e8163033b07af14b1f63330ef8b93dbf88649702f8fcc4f6ad314212fa5cbd39486b539811ec918450b3f7a716f96c
DIST pytest-mock-2.0.0.tar.gz 24665 BLAKE2B 31a3464e8bff5a2109716e95492ce1d59f2555769e69cccf4012bc268f88c5eeca99924006bdc78cc5e20cf227860d845bead9656aba1c081da58effb38ea100 SHA512 8bd7f634afebeae628470270c81f0198647bf8cd5b0fac438891d881d9823e40e814d598670bb9c9722b864990958e69d385c7c6a6e2adc81d2adcb303fbe0b0
DIST pytest-mock-3.2.0.tar.gz 25569 BLAKE2B e6a1ab23142cf3d7ac9385ac221bfce680c7b982cb489306557b60ca81563718cb9b7fcbb149cccb2cf6f06de5c3fa737d28b0711a3197fbbc86e432c5f4e614 SHA512 1ff442e26339ac41414a8678303fbc7eab573964661c664ef029c3b3377df4ab40173976316ef99e49dd208dc1e3c7cd0a0090f5453865343090cc9439f85fa9
DIST pytest-mock-3.3.1.tar.gz 27551 BLAKE2B 9e3602b988c0e27caa295d42d7400cbe7e3e30392511e662fa6ec16ec9fa4ef776d3e64b63b0345d1b520f753c6776103f507f91f0bad022544bfccc510b7e6b SHA512 ffd53974f82f725cf3bdbe750c1deb568ad1a12a67532eca93ff28d80b1cbcd8ebf709985f5473717c9d54345b251c1627c0567821e9e8b9e102db5c16cf7421
diff --git a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
deleted file mode 100644
index 8b643a363b3a..000000000000
--- a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-2[${PYTHON_USEDEP}]' -2)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-src_prepare() {
- if has_version dev-python/mock; then
- # test fails when standalone mock is installed
- sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
- fi
- sed -e 's|^\( def \)\(test_failure_message_with_no_name(\)|\1_\2|' \
- -e 's|^\( def \)\(test_failure_message_with_name(\)|\1_\2|' \
- -e 's|^\(def \)\(test_detailed_introspection(\)|\1_\2|' \
- -e 's|^\(def \)\(test_assert_called_args_with_introspection(\)|\1_\2|' \
- -e 's|^\(def \)\(test_assert_called_kwargs_with_introspection(\)|\1_\2|' \
- -i tests/test_pytest_mock.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH}
- py.test -vv tests/test_pytest_mock.py || die "Tests fail with ${EPYTHON}"
-}