summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-27 17:58:28 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-27 17:59:08 +1200
commitcd51753fee01d7893a495c58fc5da167c3e693fa (patch)
tree1ffcad4c1f0c17be3fee9921d0f3227d39a39b54
parentdev-ruby/faker: add 2.13.0 (diff)
downloadgentoo-cd51753f.tar.gz
gentoo-cd51753f.tar.bz2
gentoo-cd51753f.zip
dev-perl/Config-Auto: -r bump for EAPI7
- EAPI7 - Parallel tests - Remove unused/useless variables assignments - Unconditionally patch bad tests Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Config-Auto/Config-Auto-0.440.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Config-Auto/Config-Auto-0.440.0-r1.ebuild b/dev-perl/Config-Auto/Config-Auto-0.440.0-r1.ebuild
new file mode 100644
index 000000000000..ced43262e822
--- /dev/null
+++ b/dev-perl/Config-Auto/Config-Auto-0.440.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BINGOS
+DIST_VERSION=0.44
+inherit perl-module
+
+DESCRIPTION="Magical config file parser"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Config-IniFiles
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/IO-String
+ virtual/perl-Text-ParseWords
+ >=dev-perl/YAML-0.670.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ t/99_pod.t
+)