summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-18 16:44:03 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-18 16:45:11 +0200
commitcd68cdb2b2a14d513d68194ec1fdfd53f15e4c3f (patch)
tree6a8bf53dbb723d1e2f51d5ea254d3ba7219b987a
parentgames-util/uglygs: Clean up patches. (diff)
downloadgentoo-cd68cdb2b2a14d513d68194ec1fdfd53f15e4c3f.tar.gz
gentoo-cd68cdb2b2a14d513d68194ec1fdfd53f15e4c3f.tar.bz2
gentoo-cd68cdb2b2a14d513d68194ec1fdfd53f15e4c3f.zip
dev-util/clair: Version bump to 2.0.4
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-util/clair/Manifest1
-rw-r--r--dev-util/clair/clair-2.0.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/clair/Manifest b/dev-util/clair/Manifest
index 3846915dfb69..724946ce054f 100644
--- a/dev-util/clair/Manifest
+++ b/dev-util/clair/Manifest
@@ -1 +1,2 @@
DIST clair-2.0.3.tar.gz 5194681 BLAKE2B b4f809e7699fbf66745c7f528f3f2c249e81541a64c540a8c39b9fa8f5b581d1297abdfe80bdb0ca3aec00010c6c95e8073397df284d2a92a3e95f91049cde80 SHA512 bf2d4ab15efc50bce3e828d0510ceb44463a6c1d978a854b3a05899996203a7c33bb6e60470eccb6e0a1e23b8ff41955cd0fdda4b77a9a7e042e1e27dd2e0885
+DIST clair-2.0.4.tar.gz 5194393 BLAKE2B 631ab14acfcf516a5dd65753fe2088dbabf1c7d13a6b079cb09f0c6a3000b346da948d9c6edd16c999753342d67b9bb2165a1b38956ee8957b48953d10490430 SHA512 fee3b9fe2865c0e352b454767383bf47d67bd14f7d08171197350c20f32bc80eb318db10c9fd4bd9da0024dac97ae287cb8dcc7605c3094f4d567122bfe3f7ed
diff --git a/dev-util/clair/clair-2.0.4.ebuild b/dev-util/clair/clair-2.0.4.ebuild
new file mode 100644
index 000000000000..1cb27791309a
--- /dev/null
+++ b/dev-util/clair/clair-2.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/coreos/clair"
+EGIT_COMMIT="v${PV}"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Vulnerability Static Analysis for Containers"
+HOMEPAGE="https://github.com/coreos/clair"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/rpm
+ app-arch/xz-utils
+ dev-vcs/git
+ !!sci-visualization/xd3d" # File collision (Bug #621044)
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/${PN} -v ${EGO_PN}/cmd/${PN} || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ pushd src/${EGO_PN} || die
+ dodoc {README,ROADMAP,CONTRIBUTING}.md
+ insinto /etc/${PN}
+ doins config.example.yaml
+ popd || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}