summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-22 14:36:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-22 16:09:28 +0200
commitcd6e654846fa3a26a95497419343a485c3879c33 (patch)
treeaf0902ae28862726aa60b43e3fe90ad67a62771c
parentdev-util/cmake: Switch back to xdg-utils.eclass to avoid deps (diff)
downloadgentoo-cd6e654846fa3a26a95497419343a485c3879c33.tar.gz
gentoo-cd6e654846fa3a26a95497419343a485c3879c33.tar.bz2
gentoo-cd6e654846fa3a26a95497419343a485c3879c33.zip
app-office/libreoffice: Set IUSE="+dbus", gtk requires sys-apps/dbus[X]
Try to fix 'minimalist WM' corner case. Closes: https://bugs.gentoo.org/716712 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-office/libreoffice/libreoffice-6.4.9999.ebuild5
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-6.4.9999.ebuild b/app-office/libreoffice/libreoffice-6.4.9999.ebuild
index 96cb01612639..e42e510981a9 100644
--- a/app-office/libreoffice/libreoffice-6.4.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.4.9999.ebuild
@@ -64,12 +64,13 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+IUSE="accessibility bluetooth +branding coinmp +cups +dbus debug eds firebird
googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
bluetooth? ( dbus )
+ gtk? ( dbus )
libreoffice_extensions_nlpsolver? ( java )
libreoffice_extensions_scripting-beanshell? ( java )
libreoffice_extensions_scripting-javascript? ( java )
@@ -164,7 +165,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
- dbus? ( sys-apps/dbus )
+ dbus? ( sys-apps/dbus[X] )
eds? (
dev-libs/glib:2
gnome-base/dconf
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 536c445e0306..3e5059a20356 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -68,12 +68,13 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+IUSE="accessibility bluetooth +branding coinmp +cups +dbus debug eds firebird
googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
bluetooth? ( dbus )
+ gtk? ( dbus )
libreoffice_extensions_nlpsolver? ( java )
libreoffice_extensions_scripting-beanshell? ( java )
libreoffice_extensions_scripting-javascript? ( java )
@@ -168,7 +169,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
- dbus? ( sys-apps/dbus )
+ dbus? ( sys-apps/dbus[X] )
eds? (
dev-libs/glib:2
gnome-base/dconf