summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-10-03 20:45:04 +0200
committerPacho Ramos <pacho@gentoo.org>2021-10-03 20:45:04 +0200
commitcd78136faaf47d38b51f0a8526c70e377f22fbd1 (patch)
treeb6138072a62638d26e1dfb30272ab9f216d9c73c
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-cd78136f.tar.gz
gentoo-cd78136f.tar.bz2
gentoo-cd78136f.zip
sci-libs/libcifpp: Bump to 2.0.0
Package-Manager: Portage-3.0.24, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-libs/libcifpp/Manifest2
-rw-r--r--sci-libs/libcifpp/libcifpp-2.0.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/Manifest b/sci-libs/libcifpp/Manifest
index 485b69a8d7aa..f4e01d1d6a73 100644
--- a/sci-libs/libcifpp/Manifest
+++ b/sci-libs/libcifpp/Manifest
@@ -1,2 +1,4 @@
DIST components-1.1.1.cif.gz 80378687 BLAKE2B 0776d79f733762ad19177bc93a5587e90966a7862f84174ede23a5875ae4633b519168b24b1c02d7afb30f9049d48434921a70c097a7e8238a5745f1676dcc78 SHA512 fc68513b37871677beb60855e82ed5831e10b08340697a97bbc7113d4c898b8e8382d097d36793346e34b97f0b5def5312fe7eb81ab4f120ad3908ee8d6d1aa3
+DIST components-2.0.0.cif.gz 80878869 BLAKE2B 183c1227f403466fa543575243176d84e72bf224a70500876c77a52f0c8e1af80e99ed8cd8b428c7adc822e7006501a0cfc414e60a2896b1f53b98a116e3e4d8 SHA512 b1212155b8d6c593593013b1b39b9c711e85c1bf9b68d412dda25720ab94d82ace4445f47f832a66901d0ed5773e2d2cc5dde7a9170b9294c506edd6843d6d66
DIST libcifpp-1.1.1.tar.gz 978553 BLAKE2B 750cf80bac769a3db86b3be03924402da0254e69206a15222a5dfaa23a7eadcac1f57eb054f2fc783c287bfed86dab0a75d2994b031cc3cd3c2431a26e250d17 SHA512 e74419dada21ea12423c404c34eeb0b410fdb0b26827cd4451375329668909879b6d4795451c6f7c2b2ffc8d282dfcff2f1800630a3487111404335be4cb338f
+DIST libcifpp-2.0.0.tar.gz 996947 BLAKE2B 58568f18b17d79d8f3e2487035b505d814e0343bb56a2b18665651a3788b54d5330309c3c27b6f4636ab5e9bf3f85ebdb1a4fc8ed67adc7941559c481135f873 SHA512 8ca3f0445dad758f7fd63a0039fbe3267420d2b51036cd67a38d925b498c8ac580b86a9900317c63b4705a4a9fc9c3ef1036d40fd3f20f8eff2d6e6e5da7b735
diff --git a/sci-libs/libcifpp/libcifpp-2.0.0.ebuild b/sci-libs/libcifpp/libcifpp-2.0.0.ebuild
new file mode 100644
index 000000000000..1f190d58f576
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:0=[threads(+)]
+"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ mkdir data || die
+ cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DUSE_RSRC=OFF
+ -DCIFPP_BUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}