summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-06-26 00:50:48 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-06-26 00:52:47 +0200
commitcd8facfff575a005ef0177d2475948d0f08eaf81 (patch)
tree965358fea29a892680fdd287679ec21313211ba7
parentapp-crypt/tpm2-tss: drop 3.2.0-r4, 3.2.1, 3.2.2, 4.0.0 (diff)
downloadgentoo-cd8facfff575a005ef0177d2475948d0f08eaf81.tar.gz
gentoo-cd8facfff575a005ef0177d2475948d0f08eaf81.tar.bz2
gentoo-cd8facfff575a005ef0177d2475948d0f08eaf81.zip
sys-fs/e2fsprogs: Fix build with musl-1.2.4 (on mips o32)
* -D_GNU_SOURCE is not needed anymore (the line is from 2012) * Append -D_FILE_OFFSET_BITS=64 to flags only on musl * Keep --disable-largefile only on glibc ... Bug: https://bugs.gentoo.org/908892 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.47.0-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.47.0-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.47.0-r1.ebuild
index 580ff96d90bc..ed3a2e8d4f31 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.47.0-r1.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.47.0-r1.ebuild
@@ -68,8 +68,8 @@ multilib_src_configure() {
# Keep the package from doing silly things, bug #261411
export VARTEXFONTS="${T}/fonts"
- # Needs open64() prototypes and friends
- append-cppflags -D_GNU_SOURCE
+ # needed for >=musl-1.2.4, bug 908892
+ use elibc_musl && append-cflags -D_FILE_OFFSET_BITS=64
local myeconfargs=(
--with-root-prefix="${EPREFIX}"
@@ -85,10 +85,12 @@ multilib_src_configure() {
--disable-fsck
--disable-uuidd
--disable-lto
- --disable-largefile # need to check effect on ABI
--with-pthread
)
+ # need to check effect on ABI (???)
+ use elibc_glibc && myeconfargs+=( --disable-largefile )
+
# We use blkid/uuid from util-linux now
if use kernel_linux ; then
export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes