summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-16 05:54:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-16 05:54:54 +0200
commitcd92b222506e214de38832bab75d1424080b521d (patch)
tree37ac6747e7cfb1f881df071ef50ff2aebb3a6ea5
parentdev-python/kombu: Remove old (diff)
downloadgentoo-cd92b222506e214de38832bab75d1424080b521d.tar.gz
gentoo-cd92b222506e214de38832bab75d1424080b521d.tar.bz2
gentoo-cd92b222506e214de38832bab75d1424080b521d.zip
dev-python/jupyter-core: Bump to 5.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter-core/Manifest1
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.3.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index f804a28de309..99f56ba4e0c6 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-5.3.0.tar.gz 83909 BLAKE2B c0e5418770a4d3527e825bcd63cb9371855f544f19493b82f49db892fc92e91fd257b07b45d7cf20760f9ac9205346b3ec533491baf45f225764e6d310524bb8 SHA512 2c63f59a9618ee01d200e233cf85d586d88976c8d545235be224f9c64a54eb3a70e8b47220cc29b8ad3c102cc6c8754c8ccff2a771899986f322def5f539e072
+DIST jupyter_core-5.3.1.tar.gz 84448 BLAKE2B 22adc8f7a0b39fa4ffd087a7c7305fa29d05d45200b69a3af6827083183292e58b3b5854b60545eb065808dffec2ae9252feb573b9450bd3014d493cb1784ed3 SHA512 752ce40c0aa71432177100f34596ad98d9907f8e2d26fcabc0bce7b4f5efb9207f1979d2db180f00d2160a84034656952640cde757186e538f7038bb0f626c7b
diff --git a/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
new file mode 100644
index 000000000000..f2aa50355f98
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest