summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 00:05:01 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 00:05:01 +0100
commitcd9d188a8f54069511f93f0846bb2cd3b5ffff7e (patch)
treea503dceaadaeffb349a9119cf2651987632285cd
parentdev-libs/libtommath: Remove old (diff)
downloadgentoo-cd9d188a.tar.gz
gentoo-cd9d188a.tar.bz2
gentoo-cd9d188a.zip
media-gfx/transfig: Fix GCC10 -fno-common
Closes: https://bugs.gentoo.org/706706 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-gfx/transfig/files/transfig-3.2.5e-gcc10-fno-common.patch30
-rw-r--r--media-gfx/transfig/transfig-3.2.5e.ebuild3
2 files changed, 32 insertions, 1 deletions
diff --git a/media-gfx/transfig/files/transfig-3.2.5e-gcc10-fno-common.patch b/media-gfx/transfig/files/transfig-3.2.5e-gcc10-fno-common.patch
new file mode 100644
index 000000000000..e0c92161e3ff
--- /dev/null
+++ b/media-gfx/transfig/files/transfig-3.2.5e-gcc10-fno-common.patch
@@ -0,0 +1,30 @@
+--- a/fig2dev/dev/gensvg.c
++++ b/fig2dev/dev/gensvg.c
+@@ -230,10 +230,12 @@
+ };
+
+ /* arrowhead arrays */
+-Point points[50], fillpoints[50], clippoints[50];
+-int npoints, nfillpoints, nclippoints;
+-int arrowx1, arrowy1; /* first point of object */
+-int arrowx2, arrowy2; /* second point of object */
++Point fillpoints[50];
++int nfillpoints;
++extern Point points[50], clippoints[50];
++extern int npoints, nclippoints;
++extern int arrowx1, arrowy1; /* first point of object */
++extern int arrowx2, arrowy2; /* second point of object */
+
+ static int tileno=0; /* number of current tile */
+
+--- a/fig2dev/fig2dev.h
++++ b/fig2dev/fig2dev.h
+@@ -127,7 +127,7 @@
+ extern char *prog, *from, *to;
+ extern char *name;
+ extern double font_size;
+-Boolean correct_font_size; /* use correct font size */
++extern Boolean correct_font_size; /* use correct font size */
+ extern double mag, fontmag;
+ extern FILE *tfp;
+
diff --git a/media-gfx/transfig/transfig-3.2.5e.ebuild b/media-gfx/transfig/transfig-3.2.5e.ebuild
index 7e9dcc63d778..668facad5ece 100644
--- a/media-gfx/transfig/transfig-3.2.5e.ebuild
+++ b/media-gfx/transfig/transfig-3.2.5e.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -54,6 +54,7 @@ src_prepare() {
epatch "${WORKDIR}/${P}-gentoo-patchset"/${PN}-3.2.5e-typos.patch
epatch "${WORKDIR}/${P}-gentoo-patchset"/${PN}-3.2.5e-man-hyphen.patch
epatch "${WORKDIR}/${P}-gentoo-patchset"/${PN}-3.2.5e-fprintf_format_warnings.patch
+ epatch "${FILESDIR}"/${PN}-3.2.5e-gcc10-fno-common.patch
sed -e 's:-L$(ZLIBDIR) -lz::' \
-e 's: -lX11::' \