summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-07 16:17:55 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-12 10:52:25 -0400
commitcda34183b7ce0788477bf076f0be6bc3603ca698 (patch)
treebb1358f95eccbf37beca001b0e096b56a1a69167
parentgnome-base/gnome-shell: Version bump to 45_alpha (diff)
downloadgentoo-cda34183b7ce0788477bf076f0be6bc3603ca698.tar.gz
gentoo-cda34183b7ce0788477bf076f0be6bc3603ca698.tar.bz2
gentoo-cda34183b7ce0788477bf076f0be6bc3603ca698.zip
gnome-extra/gnome-shell-extensions: Version bump to 45_alpha
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-45_alpha.ebuild70
-rw-r--r--profiles/package.mask1
3 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
index 0a8cc36e281e..4081ecaf8603 100644
--- a/gnome-extra/gnome-shell-extensions/Manifest
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extensions-44.0.tar.xz 227060 BLAKE2B 3f166f75c5d011f990b7dcbfc4d3d1364e480822087d35cf8f361234c482f572d89b4d4eb92be67ffdf4bae4e05de361abfc3b0d92c3c30d03f67f2bd8c25251 SHA512 d3cc58bb0e5d29646a20b02cd59ba480bf42fbf9bbe0e228ae132e19e385806e95c937b3d7bd5fe0877702ed151f972f07e345e6072c1cd02d51cb56f72854e6
+DIST gnome-shell-extensions-45.alpha.tar.xz 199192 BLAKE2B 728b2e1c510256e64eff1d39ac320d5c014a6d4a06a93d3442f1536fe450ab3d82917117d9d2e06eae29c6be42bc581785850c12603e3a78353796df353848e3 SHA512 7403bc1baa229ac8277d06d1510bc3acccd8506c73e6f03bdf484f150d8093fb7aa7b2066afe1590fad34701cb7cc259cf10711a447085d7e452833b9b739fbf
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-45_alpha.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-45_alpha.ebuild
new file mode 100644
index 000000000000..6417f8b92d6f
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-45_alpha.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org readme.gentoo-r1 meson xdg
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${DEPEND}
+ >=app-accessibility/at-spi2-core-2.46.0[introspection]
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ gnome-base/gnome-menus:3[introspection]
+ =gnome-base/gnome-shell-$(ver_cut 1)*
+ gui-libs/libadwaita[introspection]
+ media-libs/clutter:1.0[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ >=x11-wm/mutter-3.32[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the gnome-extensions-app (included with gnome-shell),
+https://extensions.gnome.org/ web interface, or modify the
+org.gnome.shell enabled-extensions gsettings key from the command
+line or a script."
+
+src_configure() {
+ local emesonargs=(
+ -Dextension_set=all
+ -Dclassic_mode=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 614f8c2e75c5..a2b2e48249ac 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -70,6 +70,7 @@ dev-perl/Gtk2-Notify
>=dev-libs/gjs-1.77
>=gnome-base/gnome-shell-45_alpha
>=gnome-base/gsettings-desktop-schemas-45_alpha
+>=gnome-extra/gnome-shell-extensions-45_alpha
>=gnome-extra/gnome-system-monitor-45_alpha
>=gui-libs/gtk-4.11
>=gui-libs/libadwaita-1.4_alpha