summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-28 12:48:28 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-28 13:52:03 +0100
commitcdb7ee09380c44b8404882f22fb99b98fdfccb25 (patch)
tree0d7db19fcd8a6591a032997fb4681252a6b348da
parentsci-geosciences/gnome-maps: add depend on glib-utils (diff)
downloadgentoo-cdb7ee09.tar.gz
gentoo-cdb7ee09.tar.bz2
gentoo-cdb7ee09.zip
sci-geosciences/gnome-maps: 3.26.2 → 3.30.3
Switch to meson build system. Move introspection dependencies to RDEPEND + DEPEND as they are actually needed for both. Require gjs-1.50 as it seems requirement was downgraded by accident after 3.28. Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-3.30.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 0b22a7b1d147..331526866d48 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-3.24.3.tar.xz 1145872 BLAKE2B bd6e9652c341def652beea966d3a171a050219f3bc83288bd83eacb069899cd94d154d53bcea081bdfefdeee9b74e56c158c703ed92c9fcb5e35ecd718900e4a SHA512 b4a4c278359803e11b1aa43fb522a84b95eecfc349a134322f45db7acfe93867a61f6bd48e55a07d5d602b8161cdf5949a6b5d4da1212659e133260063ab6198
DIST gnome-maps-3.26.2.tar.xz 1175944 BLAKE2B abd8a592c10e31f4a05a6f3ef1167d111ab19a957e2fd3efa78f6999f60f98ff1767bcde18c6fb56bd6af580fd5e619106371214a92c4c450fe16df6fa4d8e23 SHA512 15548d834cf859b1d67111bdf81c3dc87c62c97574b89f41ae81bd5ce8bdccb10e705c7e91f5880d2528df88f85d6416302163d31c5b9d0f359451385168866b
+DIST gnome-maps-3.30.3.tar.xz 2176712 BLAKE2B 8595643ddf3f6c419fdc053561e49e62d6bd6e3713d3d809d3fe73cd1aecf3361e3f6592fb53d6963cbdd5fc3edaf1dcb616059da9e5e506a3399d00a9a65de7 SHA512 f3481266c6cf792da71ef40ce489c13fdd807dab91238e02b815b25e29119ffb56212fb03078e14004cca27e24906af1b94f7f3c4325bbf4f332c782c79d8203
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.30.3.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.30.3.ebuild
new file mode 100644
index 000000000000..9d2b7e48e515
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-3.30.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/gjs-1.50.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}