summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-10 04:00:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-10 04:02:34 +0200
commitcdcb050c4d76e3bd89c38bac31723f819c07276f (patch)
tree967e46d9143f9df390020bdcd39ef02c5c9e314a
parentdev-python/pygraphviz: Bump to 1.13 (diff)
downloadgentoo-cdcb050c4d76e3bd89c38bac31723f819c07276f.tar.gz
gentoo-cdcb050c4d76e3bd89c38bac31723f819c07276f.tar.bz2
gentoo-cdcb050c4d76e3bd89c38bac31723f819c07276f.zip
dev-python/sybil: Bump to 6.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 64b0a17a44bc..9142a713ce46 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-6.1.0.gh.tar.gz 70823 BLAKE2B dfdd931f1f2bb7944a97ceb92425e55accc8d7587c829b65be9b6b65007f8a32b076938e1114bbee76d0a9592ba29335cf88e982aa00d1a3ad17c8523f162548 SHA512 2048073c8ef8a9c0f71dabe39ada1404eef3d83509fe3f3e0a7e6b5d1f65a24242c8faf14aaac9ea12b21ab5908dee9bae9d03d9907f09a830d73a3b6e52f8d3
+DIST sybil-6.1.1.gh.tar.gz 71447 BLAKE2B 44ced68adfae094454c9dc4ae55b7327fc9d149728ec9f2faafc42057bc9e99572289100e310f16afdde7741841964a365c008fc9a16092d270ce88dfb0d89be SHA512 f14bb09b8886bd17ccd3a56d3dfc8e2ff510ad04f7b9c8deadff826571e36547934af6855e0a6cbed43e0c0767a0f0af8f80afcecf4a8db74b041fae9d84bd5a
diff --git a/dev-python/sybil/sybil-6.1.1.ebuild b/dev-python/sybil/sybil-6.1.1.ebuild
new file mode 100644
index 000000000000..adf69fd38724
--- /dev/null
+++ b/dev-python/sybil/sybil-6.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}