summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2020-07-24 22:14:43 -0400
committerSam James <sam@gentoo.org>2020-09-04 20:53:51 +0000
commitcdd9fdf8b17e722370f3b10daa5193ab1dd70625 (patch)
tree58fb1ad503831218bd04bd2be1eefae30bdf9c58
parentnet-libs/tox: remove old ebuild version 0.2.10 (diff)
downloadgentoo-cdd9fdf8.tar.gz
gentoo-cdd9fdf8.tar.bz2
gentoo-cdd9fdf8.zip
net-libs/tox: set tests to run with only one thread
It seems that the bug occurs from the tests being run in parallel. This commit prevents that. Closes: https://bugs.gentoo.org/730434 Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/tox/tox-0.2.11.ebuild4
-rw-r--r--net-libs/tox/tox-0.2.12.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/net-libs/tox/tox-0.2.11.ebuild b/net-libs/tox/tox-0.2.11.ebuild
index bd541befcf1b..d293d7067869 100644
--- a/net-libs/tox/tox-0.2.11.ebuild
+++ b/net-libs/tox/tox-0.2.11.ebuild
@@ -80,6 +80,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ cmake_src_test -j1
+}
+
src_install() {
cmake_src_install
diff --git a/net-libs/tox/tox-0.2.12.ebuild b/net-libs/tox/tox-0.2.12.ebuild
index f6c830c2713e..3723ccda4d62 100644
--- a/net-libs/tox/tox-0.2.12.ebuild
+++ b/net-libs/tox/tox-0.2.12.ebuild
@@ -80,6 +80,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ cmake_src_test -j1
+}
+
src_install() {
cmake_src_install