summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:06:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 18:06:16 +0200
commitcde6e14be8d6b0d4903666756afd60923b0f6799 (patch)
tree6c9d4e667c4ae108ab406edae9b6c0fd2072c324
parentros-meta/nodelet_core: Initial import. Ebuild by me. (diff)
downloadgentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.tar.gz
gentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.tar.bz2
gentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.zip
dev-ros/actionlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.11.4.ebuild25
-rw-r--r--dev-ros/actionlib/actionlib-9999.ebuild25
-rw-r--r--dev-ros/actionlib/metadata.xml5
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
new file mode 100644
index 000000000000..507a4b62258a
--- /dev/null
+++ b/dev-ros/actionlib/Manifest
@@ -0,0 +1 @@
+DIST actionlib-1.11.4.tar.gz 96491 SHA256 3584d822bd4c5254fe6f33cee833fb8703036bbdb7fa51e194b7ff5db3510281 SHA512 5bd416a1915373b6cf6f9599e115053b11b6892060438264f3e90f82a86f6c070ff0dd3f89bf3a6c4d930c20cceaa99da092346f04649ddd3286463dd43a6208 WHIRLPOOL ff8600d8a28f36776630b2462dd18ef540770d2ec1d36105e9a0393540dba8d7daf601510502ae3ccf85152b8f127f4cc0e73404842a0c65e74cd985be33c9bf
diff --git a/dev-ros/actionlib/actionlib-1.11.4.ebuild b/dev-ros/actionlib/actionlib-1.11.4.ebuild
new file mode 100644
index 000000000000..b53dcae9597f
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/actionlib/actionlib-9999.ebuild b/dev-ros/actionlib/actionlib-9999.ebuild
new file mode 100644
index 000000000000..b53dcae9597f
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/actionlib/metadata.xml b/dev-ros/actionlib/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/actionlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>