summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-01 02:20:24 +0000
committerMichał Górny <mgorny@gentoo.org>2020-08-02 08:45:42 +0200
commitce03de844b82acd847aa463a018520d6fdfb51a2 (patch)
tree85d2c2b9634e234f5d53ba72788179704ebf77af
parentdev-python/pyopengl: add Python 3.9 (diff)
downloadgentoo-ce03de84.tar.gz
gentoo-ce03de84.tar.bz2
gentoo-ce03de84.zip
dev-python/mpmath: add Python 3.9
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mpmath/mpmath-1.1.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/mpmath/mpmath-1.1.0.ebuild b/dev-python/mpmath/mpmath-1.1.0.ebuild
index 83effa8f6031..4d5812aabbd1 100644
--- a/dev-python/mpmath/mpmath-1.1.0.ebuild
+++ b/dev-python/mpmath/mpmath-1.1.0.ebuild
@@ -3,9 +3,9 @@
EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
-inherit distutils-r1 eutils
+inherit distutils-r1 eutils virtualx
DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
HOMEPAGE="http://mpmath.org/"
@@ -27,16 +27,17 @@ DEPEND="${RDEPEND}
python_prepare_all() {
local PATCHES=(
"${FILESDIR}/${PN}-1.0.0.patch"
- )
-
- # this test requires X
- rm ${PN}/tests/test_visualization.py || die
+ )
distutils-r1_python_prepare_all
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
pushd ${PN}/tests >/dev/null
- ${EPYTHON} runtests.py -local
+ ${EPYTHON} runtests.py -local || die "Tests failed with ${EPYTHON}"
popd >/dev/null
}