summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-07-19 12:18:59 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-07-19 12:18:59 +0000
commitce1dde184e4335acea9af614c1607922bd8698d5 (patch)
tree7752f231f9b87403ae19b4b53eacd0cf5466cbb3
parentnet-dialup/rp-pppoe: Fixed HOMEPAGE. (diff)
downloadgentoo-ce1dde184e4335acea9af614c1607922bd8698d5.tar.gz
gentoo-ce1dde184e4335acea9af614c1607922bd8698d5.tar.bz2
gentoo-ce1dde184e4335acea9af614c1607922bd8698d5.zip
www-apps/drupal: Security bump to release 8.1.7 - fixes SA-CORE-2016-003 (HTTPoxy exploit).
Package-Manager: portage-2.3.0
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.1.7.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index aa75d6d7c2cf..0aa4b12090fe 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -4,3 +4,4 @@ DIST drupal-7.50.tar.gz 3286826 SHA256 82041716e1790269d09ec4a1c4cca8899d0221509
DIST drupal-8.0.6.tar.gz 11782652 SHA256 4aa4310d5e6e7d8a932b158379f27ac226cd43d01bde71d4cc3229a491992baa SHA512 99b1192eb85e04ca14d8929dbea1cb658542027efa7f2a8c67a0572a2f6266ada375f700d176c6b6c858062fb1845fd0991e76c54929a2ca41a336f38cf0b492 WHIRLPOOL 07b3b09b272f404123733710738418eded39ea10a5afcbc39659c6eab5550deaa18b0d9f33be33cf1647fe47f36af905c5f5ade02ce031f81bfb23e543775a68
DIST drupal-8.1.3.tar.gz 12552870 SHA256 178e5ad63839ba52904925a4e230146786bb7fce7f25a2ff57f835a390689176 SHA512 526672e8c2d4858cfaece25ed9fbea680d4adc9ef8d0ff57e291bd524cd8dc3f434e9603be4bb46aff2c14fbc6a27c7f9939a416cbd829913276545db6b34073 WHIRLPOOL e9d6f9651defdf9786611a61785598d88299bdf0a3263a94a3a978345cd09c230530f2605284119f2dc5b11f02bb9990286deee3d02a708efad6029bafc4beeb
DIST drupal-8.1.5.tar.gz 12596430 SHA256 66590d33ba123e0b399dd9588cf3fd3b6cfbc146fc238a3f4f7d05271ae66548 SHA512 733d27b9aae4dde71582e3ad9bbb274f7ee66bba0a0860febf306b0ea16d3e200770a41f8eedc9cf69bccbaebb0e75f7244ca073a0e88d4cfeb82a60e477c1a1 WHIRLPOOL 04e360cd828f3f830ec1a422f0a22a21f344030b969cd9747f4953bfc0a89981561970f58153e1f602dc393c6684546ab57605bb14e71ef5abd1ae7d06ba5c34
+DIST drupal-8.1.7.tar.gz 12601662 SHA256 1d4c9d58c22651aca312d9fd1446f28f16018326a03e3f40dfcce264212a8e2e SHA512 bad9ef2ede85af0cd7f254c5b7827bc98a487054c614313f791af1fe6a9a34d739500669b048ea7487bd606652e03c184fc795476928df573ccefcbf1b31a496 WHIRLPOOL d30690ff5ffad3330264e3e94856420f19605d3c54a3f224f4e367ad2a6fee583bf5be1a07523b7a0b4c423e6b2adc08498923fe82485ffd360a6af0e6d6a8c0
diff --git a/www-apps/drupal/drupal-8.1.7.ebuild b/www-apps/drupal/drupal-8.1.7.ebuild
new file mode 100644
index 000000000000..0eab0019504f
--- /dev/null
+++ b/www-apps/drupal/drupal-8.1.7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}