summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-01 19:07:30 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-01 19:17:28 +0200
commitce1fab48030ec60b3b3696140602b4e42f46a0f9 (patch)
tree92f5303e5294149177b5bd945e5ef2a365d8edfe
parentsys-cluster/galera: amd64 stable wrt bug #647094 (diff)
downloadgentoo-ce1fab48.tar.gz
gentoo-ce1fab48.tar.bz2
gentoo-ce1fab48.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.2
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index b850114e4328..4167f9dec051 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-screenshooter-1.8.2.tar.bz2 492524 BLAKE2B 88b0ea17331c9ffc25928df29b708d6f9cbbc844f5048f40bf29e22925e6326761a0a693601cfecf950bc61f97a0e9873f3d85e743a3e497d2fe19d6fc2f26e1 SHA512 e43dce108c7bacfeebdc39b0c9948b348c77faf358fb0ab5f26d59c96980f1c5473ef87895fe53387340202813935ddad6e200010e61aa27c2c56b662ee56b1e
DIST xfce4-screenshooter-1.9.1.tar.bz2 514979 BLAKE2B d66aa03561aaed01181710356fbde95d390575a87676eece6bd90b32e107e8cbc7b065a8c91b6badf8e9041d027280f8777dcfefbcea6f09cb1e096ffff091bb SHA512 e95385f65dfe5fdd1d7045a18c9404ab400db9ddd06a35de2b11c0a955b390a6d278903a3558c135ee9744c8062860f491339b5d035f53cac74a49c366bd8bb2
+DIST xfce4-screenshooter-1.9.2.tar.bz2 504757 BLAKE2B 6c22e409974b6251a756f0b7addd91850d4454b0a725623dd47dd3dc29d8e3f6037bd69ef6bfcb363f4a6f2512062e80779a07b4ab1f77dc9ca0b6db5361a5b5 SHA512 fb60fe89a620122e59352154dbcace8f3e3a2f2f3f2d6cfff521651f4dc021241e9b370f7929fca55b36bbb13ed3ae0c4393a621291b51e451bc2e57b1a798c8
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.2.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.2.ebuild
new file mode 100644
index 000000000000..9139ec91154d
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}