summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 17:28:45 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 17:32:48 +0100
commitce21e3f6763f60f512de08415874ce8dd3de9159 (patch)
tree517ab0d109af63467e5396440d149626cb626c7b
parentdev-python/pywinrm: initial import (diff)
downloadgentoo-ce21e3f6.tar.gz
gentoo-ce21e3f6.tar.bz2
gentoo-ce21e3f6.zip
dev-python/pytest-testinfra: initial import
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/metadata.xml19
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
new file mode 100644
index 000000000000..37bc260fa2e1
--- /dev/null
+++ b/dev-python/pytest-testinfra/Manifest
@@ -0,0 +1 @@
+DIST pytest-testinfra-6.3.0.tar.gz 76309 BLAKE2B 95b4a6ac5ea3c3db2afdd537209bfeb2c188ec7c7935b73e831733fbbf2540b8769d1187338b3b9c9da997cd653e800004e7199537d95530967cd73a15cb2c2e SHA512 ff0add6bdadac92f6f997a94734d69d39598bc8d1f7689a6b269e59bc886825fcf8a42968c2d34a9ad7e77ed0112bf4044afede8e0dca2bbddc76c9c5612ae92
diff --git a/dev-python/pytest-testinfra/metadata.xml b/dev-python/pytest-testinfra/metadata.xml
new file mode 100644
index 000000000000..75d52d73c62c
--- /dev/null
+++ b/dev-python/pytest-testinfra/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ With Testinfra you can write unit tests in Python to test actual state of your servers
+ configured by management tools like Salt, Ansible, Puppet, Chef and so on.
+
+ Testinfra aims to be a Serverspec equivalent in Python.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-testinfra</remote-id>
+ <remote-id type="pypi">pytest-testinfra</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
new file mode 100644
index 000000000000..8081571a974a
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}