summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 22:33:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:27 -0500
commitce30c10a26d6a95ddcddf330e22140d577aa2f2d (patch)
treea3e8e30b04ad0b32293fd8b24674679524865230
parentdev-python/rednose: add py37 support for 0.4.1 (diff)
downloadgentoo-ce30c10a26d6a95ddcddf330e22140d577aa2f2d.tar.gz
gentoo-ce30c10a26d6a95ddcddf330e22140d577aa2f2d.tar.bz2
gentoo-ce30c10a26d6a95ddcddf330e22140d577aa2f2d.zip
dev-python/sure: add py37 support to 1.2.5-r1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/sure/sure-1.2.5-r1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/sure/sure-1.2.5-r1.ebuild b/dev-python/sure/sure-1.2.5-r1.ebuild
index fa76a8a27c7e..f26b681d0203 100644
--- a/dev-python/sure/sure-1.2.5-r1.ebuild
+++ b/dev-python/sure/sure-1.2.5-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 vcs-snapshot
+inherit distutils-r1
DESCRIPTION="Utility belt for automated testing in python for python"
HOMEPAGE="https://github.com/gabrielfalcao/sure"
@@ -26,8 +25,6 @@ DEPEND="
"
RDEPEND="${CDEPEND}"
-S="${WORKDIR}/${P}-r1"
-
python_prepare_all() {
sed \
-e "82s/read_version()/'${PV}'/" \