summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-21 14:44:47 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-06 19:00:33 +0100
commitce4e532b38ecd1875c635137951563c4614c8677 (patch)
treee2629d30f1f69a66e3977e440a865ce24ac55bc6
parentmedia-libs/oneVPL-intel-gpu: new package, add 22.6.3 (diff)
downloadgentoo-ce4e532b.tar.gz
gentoo-ce4e532b.tar.bz2
gentoo-ce4e532b.zip
media-libs/intel-mediasdk: add version 22.6.3
Closes: https://bugs.gentoo.org/799746 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--media-libs/intel-mediasdk/Manifest1
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild82
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild47
-rw-r--r--media-libs/intel-mediasdk/metadata.xml16
4 files changed, 139 insertions, 7 deletions
diff --git a/media-libs/intel-mediasdk/Manifest b/media-libs/intel-mediasdk/Manifest
index cdb35d54327a..4936a453e419 100644
--- a/media-libs/intel-mediasdk/Manifest
+++ b/media-libs/intel-mediasdk/Manifest
@@ -1 +1,2 @@
DIST intel-mediasdk-20.3.0.tar.gz 10810941 BLAKE2B 5c5bc1a8444b6780ee7ea13711e7c59f62e8c9d8a7577ff848a6fbc5fc416d3e03580fe44dd9df7a506c19dd677986804a055cb16b34a06a55897623d25298d5 SHA512 2bd2604e6f17aeeea661352fd52c19b0ff2361919ad67b858287e507e0356cc805f1d22b39ff28294d303efefc33e10c2c5912d774f1bc40751c2c6c3c9e90c4
+DIST intel-mediasdk-22.6.3.tar.gz 11657130 BLAKE2B 3f63cf85716159f38f52cd0941cb716d9a25d2635e8b6da295a8fb78898ae007c3216148db580b94aa83742803effc0c1c2b0a431414a85f6feb44c93ae04738 SHA512 bd9fb9ca5b96bb2911db7fdf2622127f0dc3e86de8dc732bc6df6f4fcb343406e3ab14ffa5ce4595ed9b3bf19a73652681137fbe5b473c812c5b74554998a2b0
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild
new file mode 100644
index 000000000000..a42d8290d2f3
--- /dev/null
+++ b/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+fi
+
+DESCRIPTION="Intel Media SDK"
+HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Intel-Media-SDK/MediaSDK/archive/intel-mediasdk-${PV}.tar.gz"
+ S="${WORKDIR}/MediaSDK-intel-mediasdk-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="dri test +tools wayland X"
+# Test not working at the moment
+#RESTRICT="!test? ( test )"
+RESTRICT="test"
+# # Most of these flags only have an effect on the tools
+REQUIRED_USE="
+ dri? ( X )
+ wayland? ( tools )
+ X? ( tools )
+"
+
+# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
+# bug #805224
+DEPEND="
+ x11-libs/libpciaccess
+ >=media-libs/libva-intel-media-driver-${PV}
+ media-libs/libva[X?,wayland?]
+ x11-libs/libdrm[video_cards_intel]
+ wayland? (
+ dev-libs/wayland
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ # OpenCL only has an effect if we build kernels
+ -DENABLE_OPENCL=OFF
+ -DBUILD_TUTORIALS=OFF
+ # Need to package the cm-compiler to build kernels, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_RUNTIME=ON
+ -DBUILD_DISPATCHER=ON
+ -DBUILD_TOOLS="$(usex tools)"
+ # Cannot build tools without samples
+ -DBUILD_SAMPLES="$(usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_X11_DRI3="$(usex dri)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+}
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
index 5e9ab6853a42..a42d8290d2f3 100644
--- a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
+++ b/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake
+inherit cmake optfeature
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
@@ -14,7 +14,7 @@ if [[ ${PV} == *9999 ]] ; then
fi
DESCRIPTION="Intel Media SDK"
-HOMEPAGE="http://mediasdk.intel.com"
+HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
else
@@ -26,18 +26,57 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="dri test +tools wayland X"
+# Test not working at the moment
+#RESTRICT="!test? ( test )"
+RESTRICT="test"
+# # Most of these flags only have an effect on the tools
+REQUIRED_USE="
+ dri? ( X )
+ wayland? ( tools )
+ X? ( tools )
+"
+
# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
# bug #805224
DEPEND="
+ x11-libs/libpciaccess
>=media-libs/libva-intel-media-driver-${PV}
+ media-libs/libva[X?,wayland?]
x11-libs/libdrm[video_cards_intel]
+ wayland? (
+ dev-libs/wayland
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
+ # OpenCL only has an effect if we build kernels
-DENABLE_OPENCL=OFF
+ -DBUILD_TUTORIALS=OFF
+ # Need to package the cm-compiler to build kernels, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_RUNTIME=ON
+ -DBUILD_DISPATCHER=ON
+ -DBUILD_TOOLS="$(usex tools)"
+ # Cannot build tools without samples
+ -DBUILD_SAMPLES="$(usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_X11_DRI3="$(usex dri)"
+ -DENABLE_WAYLAND="$(usex wayland)"
)
cmake_src_configure
}
+
+pkg_postinst() {
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+}
diff --git a/media-libs/intel-mediasdk/metadata.xml b/media-libs/intel-mediasdk/metadata.xml
index 716be526394b..888102391fdf 100644
--- a/media-libs/intel-mediasdk/metadata.xml
+++ b/media-libs/intel-mediasdk/metadata.xml
@@ -1,7 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>media-video@gentoo.org</email>
-</maintainer>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Intel-Media-SDK/MediaSDK</remote-id>
+ </upstream>
+ <use>
+ <flag name="tools">Build analyse and inspect tools</flag>
+ </use>
</pkgmetadata>