summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-01 07:23:30 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-01 07:23:30 +0200
commitce60b4c336146a31f1b362afc0012378a76c3dd9 (patch)
tree7dc32ce21764a956f9cc910cdbc8fcc9587b2d74
parentsys-fs/vhba: Bump to 20190831 (diff)
downloadgentoo-ce60b4c336146a31f1b362afc0012378a76c3dd9.tar.gz
gentoo-ce60b4c336146a31f1b362afc0012378a76c3dd9.tar.bz2
gentoo-ce60b4c336146a31f1b362afc0012378a76c3dd9.zip
app-cdr/cdemu: Bump to 3.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-cdr/cdemu/Manifest1
-rw-r--r--app-cdr/cdemu/cdemu-3.2.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-cdr/cdemu/Manifest b/app-cdr/cdemu/Manifest
index 469a0d6f7b1e..dd3a3d4598d5 100644
--- a/app-cdr/cdemu/Manifest
+++ b/app-cdr/cdemu/Manifest
@@ -1,2 +1,3 @@
DIST cdemu-client-3.2.1.tar.bz2 43584 BLAKE2B d34c09203b7b4e70161d62aee48d531b083952174fd2357bf0fc7b69a0fd59200bedb9ca87fe2d2c18c953979c84e9db3fec4d5fb500375f0bcc155dcaf5cedb SHA512 913c26754d16c339d7ddb4e00cc7d5b754ad6cc7f1a156c9448b51ed09468cf9e8a2bc74ed123a621278d2ad281e447d33ee06c3416bc1d0d2e6c2becd539154
DIST cdemu-client-3.2.2.tar.bz2 44305 BLAKE2B 3a656bfda48a502752cb2b14df413a26467a1512b867cc1519f3dfd21b764a8086135a70b13272f258eb079ce169f58af55665e56238a7ba57cf4e9d84f07751 SHA512 ab5c1b1c741945618581bedb18a6eebdcb55915dc811e4247f0c3afe17729f7fbfaaaec10302e444a2f237c5a1401aa402a614685a84c63442907982e759ff41
+DIST cdemu-client-3.2.3.tar.bz2 44311 BLAKE2B 23451618897a5281478c9d70ded357089a4baaf47b22f36b4add9c5d2c899478629ce034cce0e593b501a127cdc1f5527f0aaf1951f709bf4c2d131e898045a2 SHA512 5d98870fa42bb639009dc6971747f252f3403eda882bffacf55f647193a1a9fb7a75ad69a7512da3abdcdeb64510b0f163ea997c4d75a804fa93880b62b03dd6
diff --git a/app-cdr/cdemu/cdemu-3.2.3.ebuild b/app-cdr/cdemu/cdemu-3.2.3.ebuild
new file mode 100644
index 000000000000..dc34238bf6a4
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-3.2.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit bash-completion-r1 cmake-utils python-single-r1 xdg-utils
+
+MY_P=cdemu-client-${PV}
+DESCRIPTION="Command-line tool for controlling cdemu-daemon"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-client/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cdemu-daemon"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
+DEPEND="
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ python_fix_shebang src/cdemu
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPOST_INSTALL_HOOKS=OFF
+ -DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}