summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-06-28 08:26:24 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-07-01 14:52:12 -0400
commitce68f27aaad01c7e0e4af540d8bd1fc7cf03fd13 (patch)
tree91c5f528f3dc935b09e13a6912a598b3a9880803
parentsys-apps/systemd: add 249_rc3, drop 249_rc2 (diff)
downloadgentoo-ce68f27aaad01c7e0e4af540d8bd1fc7cf03fd13.tar.gz
gentoo-ce68f27aaad01c7e0e4af540d8bd1fc7cf03fd13.tar.bz2
gentoo-ce68f27aaad01c7e0e4af540d8bd1fc7cf03fd13.zip
sci-mathematics/lcalc: new package for L-function computations.
Closes: https://bugs.gentoo.org/230439 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/lcalc/Manifest1
-rw-r--r--sci-mathematics/lcalc/lcalc-2.0.1.ebuild31
-rw-r--r--sci-mathematics/lcalc/metadata.xml37
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/lcalc/Manifest b/sci-mathematics/lcalc/Manifest
new file mode 100644
index 000000000000..6ba64e4dd9ce
--- /dev/null
+++ b/sci-mathematics/lcalc/Manifest
@@ -0,0 +1 @@
+DIST lcalc-2.0.1.tar.xz 849260 BLAKE2B 141044939b50903f5aa631ee7ca76ed1ffc65fd0604701376b67172a8f70bcded2a9303ac3f653b20b8a05da44034f21f775dbe98f6efd38cd4097957f5f5466 SHA512 cf7210cd79dad416e3c4cdc08a6ed276d88483b8dfc425fe2ed4a1592b8a31f82ed5ec7cc7b6308ac80d44cf20e9a07484e2004bbfdeabbbabf843d24d15cc2a
diff --git a/sci-mathematics/lcalc/lcalc-2.0.1.ebuild b/sci-mathematics/lcalc/lcalc-2.0.1.ebuild
new file mode 100644
index 000000000000..31632d687e6c
--- /dev/null
+++ b/sci-mathematics/lcalc/lcalc-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line utility and library for L-function computations"
+HOMEPAGE="https://gitlab.com/sagemath/lcalc"
+SRC_URI="https://gitlab.com/sagemath/lcalc/uploads/01b46cdbbf3e67a322320dc0b2750d50/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+# The subslot is the libLfunction soname major version
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+# Omit USE=mpfr for now because it's broken upstream:
+#
+# https://gitlab.com/sagemath/lcalc/-/issues/7
+#
+IUSE="+double double-double quad-double pari"
+REQUIRED_USE="^^ ( double double-double quad-double )"
+
+BDEPEND="dev-util/gengetopt"
+DEPEND="double-double? ( sci-libs/qd:= )
+ quad-double? ( sci-libs/qd:= )
+ pari? ( sci-mathematics/pari:= )"
+REPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with pari) \
+ --enable-precision="$(usev double)$(usev double-double)$(usev quad-double)"
+}
diff --git a/sci-mathematics/lcalc/metadata.xml b/sci-mathematics/lcalc/metadata.xml
new file mode 100644
index 000000000000..9a24558f38a7
--- /dev/null
+++ b/sci-mathematics/lcalc/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">sagemath/lcalc</remote-id>
+ </upstream>
+ <use>
+ <flag name="double">Use double precision (the upstream default)</flag>
+ <flag name="double-double">
+ Use <pkg>sci-libs/qd</pkg>for double-double precision
+ </flag>
+ <!-- Broken upstream: https://gitlab.com/sagemath/lcalc/-/issues/7
+ <flag name="multiple-precision">
+ Use <pkg>dev-libs/mpfr</pkg>for multiple precision
+ </flag>
+ -->
+ <flag name="pari">
+ Use <pkg>sci-mathematics/pari</pkg> for elliptic curve L-functions
+ </flag>
+ <flag name="quad-double">
+ Use <pkg>sci-libs/qd</pkg>for quad-double precision
+ </flag>
+ </use>
+</pkgmetadata>