summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-10 00:36:18 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-10 00:55:06 +0200
commitce6d6209838bfea7dd56e7beabfed488c7bb4e5a (patch)
treebaea3e741160306c2e94e8e558ca10e7cf4eb027
parentgnome-extra/gnome-clocks: version bump from 3.20.1 to 3.20.2 (diff)
downloadgentoo-ce6d6209.tar.gz
gentoo-ce6d6209.tar.bz2
gentoo-ce6d6209.zip
app-text/iso-codes: version bump 3.68 → 3.70
Package-Manager: portage-2.3.0
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-3.70.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index d15fa83cc72e..7c72b0797b5f 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,4 @@
DIST iso-codes-3.63.tar.xz 3773672 SHA256 60600e56952dc92b3a8cd8a7044348f7cfa35be528bab2491c3c18582fb5277f SHA512 31b5142611e2050a9bfb95cd12d962b8cbe01824f1202e70ca40d9cd178a5fd17557eac3fcc59dd0b94baf2656caeef09c50332cd2a8d0e1bb14c82c154e06ae WHIRLPOOL bbe3c5474ba3fc22243a9b6bea9c6b43dccd5a2230ee59b07e4484e06ccba4be977dfa1e16014b18d4cae5393a50099e3a12b13747e9970c4e605df8b4e002be
DIST iso-codes-3.65.tar.xz 3732432 SHA256 834de5193c8489eedeaf6509457a9b13476702386ae1f3ed4f391a349d630320 SHA512 cf88397150b3014a4f5e4d709cbc1e00537c9289ea68d68ec9b24df6c7467fda3fe99fbeacd444837d614ae1df213816a3996a9e86aac400f9d92a0a3090f8ab WHIRLPOOL b506fea95bba3ecf40e9d1e4d5c26d4fd97e88203fdf1e931269642b42daca93b5b479b52a4e2807de4dc80b3233599394dc67f6762bf00caf5689a74fd36e4c
DIST iso-codes-3.68.tar.xz 3448584 SHA256 5881cf7caa5adfffb14ade99138949324c28a277babe8d07dafbff521acef9d1 SHA512 77abd3437fe66635cf52dbe065def9ff229a4bce20eb1167ccc825c934db57b4acc8112f99bdca6313324d850549cd9ead7556e0540c2b4e80cad9715613cec2 WHIRLPOOL 5b905d4711ea5f3af29418829bcfbb94172336f548e125005a15f5e8963bee55f21d6c44542037d006bee06748db13f8a30b8474163c0bfa816dca9fa9e46ed5
+DIST iso-codes-3.70.tar.xz 3452288 SHA256 41e2fbaec2ed57e767b94f175d0dcd31b627aeb23b75cd604605a6fb6109d61f SHA512 59238008b320a739afd1cdf689f2c163d233e3fadfe9ab038bdad2502e866185867edab9f46fd078a6d46f4431267e614d0dd3b597ba17fdda95004bbaf5dd4a WHIRLPOOL e9a5dab29699386be3c3a2b16e925aa4741c260a782b2fbb88ef180682feb9f05dc6f0b88920a00c299f671677de0f5d19e61a88c9b0299c7e566a732125ab79
diff --git a/app-text/iso-codes/iso-codes-3.70.ebuild b/app-text/iso-codes/iso-codes-3.70.ebuild
new file mode 100644
index 000000000000..e6010bfc3e6a
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.70.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+PLOCALES="af am ar as ast az be bg bn bn_IN br bs byn ca crh cs cy da de dz el en eo es et eu fa fi fo fr ga gez gl gu haw he hi hr hu hy ia id is it ja ka kk km kn ko kok ku lt lv mi mk ml mn mr ms mt nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl so sq sr sr@latin sv sw ta te th ti tig tk tl tr tt tt@iqtelif ug uk ve vi wa wal wo xh zh_CN zh_HK zh_TW zu"
+
+inherit eutils l10n python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${PYTHON_DEPS}
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+# l10n_find_plocales_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if use "linguas_${loc%.po}"; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}