summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-03 05:34:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-03 05:42:45 +0200
commitce77c57e25c1cf730c6c84012850f8d6879743df (patch)
tree887716505ecccde79dba87b0e400cc015f855305
parentdev-python/joblib: Bump to 1.4.2 (diff)
downloadgentoo-ce77c57e25c1cf730c6c84012850f8d6879743df.tar.gz
gentoo-ce77c57e25c1cf730c6c84012850f8d6879743df.tar.bz2
gentoo-ce77c57e25c1cf730c6c84012850f8d6879743df.zip
dev-python/gfloat: Bump to 0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gfloat/Manifest1
-rw-r--r--dev-python/gfloat/gfloat-0.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/gfloat/Manifest b/dev-python/gfloat/Manifest
index e5873b0692c7..f7d25682b725 100644
--- a/dev-python/gfloat/Manifest
+++ b/dev-python/gfloat/Manifest
@@ -1 +1,2 @@
DIST gfloat-0.0.5.tar.gz 17493 BLAKE2B d2eb75b6ecdf58b0875481fb2428ee2bed998988ded0e0bf212dc5834c428a8a2af0796e6badf2ff2c400432db266a82312743bc338cb6444bbb3133526dcf7b SHA512 b08d4f8cb3c8e2e629d32c96ecf3efb81280363bba9ac90a489ffcd2418a9a4a0c9248ce3f524d9873a295b5e5e520c70ebd098e7cfdfe9a3dc92d8ee58920ca
+DIST gfloat-0.1.tar.gz 38500 BLAKE2B 7549af8cb4204176c8f6d9c9bbd1e8047530ca347c1f882cb3ed5ae36a8c2a3e5c1293c8e4ac14527b3846ec0055ed4bb30cef7bb703c30c375d4b8c872c1bb6 SHA512 7c5d01b25172b3e5c4dbd34e99652316f50478b0c34076608e7d56a80f5db9174a1173dc9bcbea0da2121df54e5a22a7972196ee47cb22a69bd4b8afcc1e2782
diff --git a/dev-python/gfloat/gfloat-0.1.ebuild b/dev-python/gfloat/gfloat-0.1.ebuild
new file mode 100644
index 000000000000..a3db6988220f
--- /dev/null
+++ b/dev-python/gfloat/gfloat-0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generic floating-point types in Python"
+HOMEPAGE="
+ https://github.com/graphcore-research/gfloat/
+ https://pypi.org/project/gfloat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ml-dtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest