summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-30 15:19:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-10-30 15:21:47 +0100
commitce7e1fd768f07ba40048f1ef7f987e42935c6550 (patch)
tree1fca89929e9d591ac4df747a060a964273190f7f
parentRevert "dev-python/Babel: Drop old" (diff)
downloadgentoo-ce7e1fd768f07ba40048f1ef7f987e42935c6550.tar.gz
gentoo-ce7e1fd768f07ba40048f1ef7f987e42935c6550.tar.bz2
gentoo-ce7e1fd768f07ba40048f1ef7f987e42935c6550.zip
media-libs/zimg: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/metadata.xml8
-rw-r--r--media-libs/zimg/zimg-2.0.1.ebuild37
-rw-r--r--media-libs/zimg/zimg-9999.ebuild37
4 files changed, 83 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
new file mode 100644
index 000000000000..0bd2aca20e52
--- /dev/null
+++ b/media-libs/zimg/Manifest
@@ -0,0 +1 @@
+DIST zimg-2.0.1.tar.gz 174318 SHA256 be2557bf944dad07edbaf37d3fd5f1911627294b8d0992a8530048e84df082d8 SHA512 213952b2e51fad2f92d989104be188ff6cdc71b0910a1201a5f772e45b1fa90f522a62e85d8725037560e4505f40958a5497d731f3d03f7b890bfdaa5d0ae13c WHIRLPOOL 4918e22cc76a613a1641aba55f5f2d652186ef84a5719d250dfb499d0c8be8c7dd688dcf95d18e93f152479fad4a8543addf5c9a149fc030f354a090e741bcbb
diff --git a/media-libs/zimg/metadata.xml b/media-libs/zimg/metadata.xml
new file mode 100644
index 000000000000..c572c7d9b478
--- /dev/null
+++ b/media-libs/zimg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/zimg/zimg-2.0.1.ebuild b/media-libs/zimg/zimg-2.0.1.ebuild
new file mode 100644
index 000000000000..73b4cb907342
--- /dev/null
+++ b/media-libs/zimg/zimg-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
new file mode 100644
index 000000000000..73b4cb907342
--- /dev/null
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}