summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-01 05:33:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-01 05:33:47 +0100
commitcea0604ccdeb604db316644fb6a858e1617b6569 (patch)
tree445320abc48bb662f7d73f7ff39e76fdd30fd170
parentmedia-sound/alsa-scarlett-gui: add 0.3.3, drop 0.3.2.0.0.20231129 (diff)
downloadgentoo-cea0604c.tar.gz
gentoo-cea0604c.tar.bz2
gentoo-cea0604c.zip
dev-python/botocore: Bump to 1.33.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.33.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f9c0188ef1bf..6637ab09c40c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.33.0.gh.tar.gz 12348895 BLAKE2B 14925bfa7839fb8982e53ba001ef3682
DIST botocore-1.33.1.gh.tar.gz 12352240 BLAKE2B e87e0204e3b4c2274a9bb7a9b31128cbba1d37e1ebc52509d1409afc83413db844e20cef708318657cc4a890afdc8ae5c8825b6ff95eb7634d6072a5180cd457 SHA512 ff98f47ff34d5ba2da00e06c82550f9edcd3552bec881c80882452f8d1eccbc1b57376f6026718b25fb70b1039caffd9cf0f368a06aaa26ed6607562ed345386
DIST botocore-1.33.2.gh.tar.gz 12455360 BLAKE2B 8cc7c4cea1d2cb342c63e2d335801ae2fe27e3473ffd05205b01ce33c7d7610b24960e5cb3899d7145a1dcd4a4d7b3d279e96210a8e86bcf5b192090a75204ea SHA512 f25893ebd7e172ca354b203121a7516e242ecc7c320b7f9e7b8313936710dc2fecfebe987be401de73f0c6cc8301163689ec4bff9354ebe63ae862d32d892378
DIST botocore-1.33.4.gh.tar.gz 12506808 BLAKE2B d8bba2722e13e37ef867e1565d52de439b6e143301f9ea3bcb0eeb896903f69d226041234e6ed570b9483d6cd2e3ad687a57d24a5bae66560f70939f75d1122f SHA512 a0a980d261618aba5b55bef588fc8b5c5c852d134921977d2714ba6698246955187864ab3b6219900735e8d294a58b7953bc8f226c56b06065bf1fd2e6f8f1b6
+DIST botocore-1.33.5.gh.tar.gz 12514042 BLAKE2B ba16606352fffdf478b3f1ceb0712aa0b0a18508ec0f3f4e4f9ba1c3366a2a615549e6b194101d7634bd22eebdea63ad5aa41e810ec4b733b9c09fdfaef02ba3 SHA512 1f26f58009ae84acd7b4557c04af3acc2f5f6900357419565c4fbb5ee54fc54c8593e7b21a27a9c374f4edab8b95555bd891f52f9026283df20f867ad90b74ea
diff --git a/dev-python/botocore/botocore-1.33.5.ebuild b/dev-python/botocore/botocore-1.33.5.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.33.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}