summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-09-13 13:44:25 +0300
committerMart Raudsepp <leio@gentoo.org>2017-09-16 22:38:12 +0300
commitcec0245ebe1cb1c8e3985d6db26481e594ecd3e5 (patch)
tree226ba39255febc11f26816d69dda63a42ac637c4
parentmedia-libs/libepoxy: Switch to using the meson build system (diff)
downloadgentoo-cec0245ebe1cb1c8e3985d6db26481e594ecd3e5.tar.gz
gentoo-cec0245ebe1cb1c8e3985d6db26481e594ecd3e5.tar.bz2
gentoo-cec0245ebe1cb1c8e3985d6db26481e594ecd3e5.zip
dev-lang/orc: bump to 0.4.27
Closes: https://bugs.gentoo.org/625586 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-lang/orc/Manifest1
-rw-r--r--dev-lang/orc/orc-0.4.27.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index 565297a9d58b..d5b31e53bce9 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1 +1,2 @@
DIST orc-0.4.26.tar.xz 465768 SHA256 7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649 SHA512 c0b02d4f00b7cc45c5952a4db4f63629bbcbc4d338bbe69fd2743198f2b346bf437742a7a8e1d308f765caf1b43f7fab75add7ebf69897bc0e335a169eef7326 WHIRLPOOL 019891cc9272315666b9b68eb439002192d676794bb7b8b490353991b152a6deadb5171bf46b0e4894c2372b77935e2578b9a0221e6172a8ccfa6f7966983c8c
+DIST orc-0.4.27.tar.xz 465116 SHA256 51e53e58fc8158e5986a1f1a49a6d970c5b16493841cf7b9de2c2bde7ce36b93 SHA512 5ca0b4553e370ea7c95acfc8248d9d568dafc9577041d47f52c7d0945456c534e18e0e80d28df9301d6deac1ea4f8ea6a51ca373b32927c8724846d8ec1f73e8 WHIRLPOOL 6f39e17e22c2b2f515f6081432e670fc04df81f5ebd3a1da7009eef2ca69476b91c767fdae3086bb4ff9ece52668eadd2332026dc0d457f62f870d3d9b7b10af
diff --git a/dev-lang/orc/orc-0.4.27.ebuild b/dev-lang/orc/orc-0.4.27.ebuild
new file mode 100644
index 000000000000..537d29d59cfe
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.27.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic multilib-minimal pax-utils
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples pax_kernel static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ default
+
+ # Do not build examples
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+}
+
+multilib_src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+
+ # FIXME: handle backends per arch ?
+ ECONF_SOURCE="${S}" econf \
+ --disable-gtk-doc \
+ --enable-backend=all \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+
+ if use pax_kernel; then
+ pax-mark m "${ED}"usr/bin/orc-bugreport
+ pax-mark m "${ED}"usr/bin/orcc
+ pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,*.orc}
+ fi
+}
+
+pkg_postinst() {
+ if use pax_kernel; then
+ ewarn "Please run \"revdep-pax\" after installation".
+ ewarn "It's provided by sys-apps/elfix."
+ fi
+}