summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-29 19:01:59 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-29 19:14:57 -0400
commitced32ce04eabe760e4f26785be7b38812f1fb6ab (patch)
tree4f83a7b04f1fb3cd0690a157500a8bd81ef85d13
parentapp-misc/hivex: fix REQUIRED_USE (diff)
downloadgentoo-ced32ce04eabe760e4f26785be7b38812f1fb6ab.tar.gz
gentoo-ced32ce04eabe760e4f26785be7b38812f1fb6ab.tar.bz2
gentoo-ced32ce04eabe760e4f26785be7b38812f1fb6ab.zip
dev-python/django: fix invalid metadata
Package-Manager: portage-2.3.2
-rw-r--r--dev-python/django/django-1.5.12.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/django/django-1.5.12.ebuild b/dev-python/django/django-1.5.12.ebuild
index c41ae1d733eb..b8bbde110464 100644
--- a/dev-python/django/django-1.5.12.ebuild
+++ b/dev-python/django/django-1.5.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
+PYTHON_COMPAT=( python2_7 pypy )
PYTHON_REQ_USE='sqlite?,threads(+)'
WEBAPP_NO_AUTO_INSTALL="yes"
@@ -20,17 +20,16 @@ SLOT="0"
KEYWORDS=""
IUSE="doc mysql postgres sqlite test"
-PY2_USEDEP=$(python_gen_usedep python2_7)
-PY23_USEDEP=$(python_gen_usedep python2_7 'python{3_3,3_4}')
+PY2_USEDEP=$(python_gen_usedep 'python*')
RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PY23_USEDEP}] )
+ postgres? ( dev-python/psycopg:2[${PY2_USEDEP}] )
mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
test? ( $(python_gen_impl_dep sqlite) )"
-REQUIRED_USE="mysql? ( $(python_gen_useflags python2_7) )
- postgres? ( || ( $(python_gen_useflags 'python{2_7,3_2,3_3}') ) )"
+REQUIRED_USE="mysql? ( $(python_gen_useflags 'python2*') )
+ postgres? ( || ( $(python_gen_useflags 'python2*') ) )"
S="${WORKDIR}/${MY_P}"