summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 15:52:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 16:39:37 +0100
commitcee3178a8bfd1bd75e3f33163a4eb79a1e5337f6 (patch)
tree11833738f75c26f81157d1441b2068e3b1e90b11
parentdev-python/paginate: Enable py3.12 (diff)
downloadgentoo-cee3178a8bfd1bd75e3f33163a4eb79a1e5337f6.tar.gz
gentoo-cee3178a8bfd1bd75e3f33163a4eb79a1e5337f6.tar.bz2
gentoo-cee3178a8bfd1bd75e3f33163a4eb79a1e5337f6.zip
dev-python/reportlab: Bump to 4.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-4.0.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index d0322f42c4b7..bb2a860115ad 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-4.0.6.tar.gz 3671124 BLAKE2B 4664f328f677a4e11955ad995a6c2b4d407add355b116e733051ea27706644091c7c9bac28d91486135aa89959551ed5f8ce31e11cace9c53f05f69e0ab1e9d8 SHA512 6a5426416e636115919b36baec95e531462f15bd370a17b2e80ece430775e3e2899c43ef1a0aabd6cfc7f2bc7fe25bfe3c1b2477496d34915f5f5fd24063da74
+DIST reportlab-4.0.7.tar.gz 3683030 BLAKE2B e307fd165bc66a97ad98789d8fcd128e7db789a8dbbad50451a910efd4052e850a34f7b0a65b78920c77de9309519c242640ba348005733693d1998641ca23cf SHA512 d0fa92f1553a7ac2d4df13d0ec68f8145a78ed8a702c14fb283bee6e8b05bc1afb16664d02313154d40875712de2767b2b2d93f78c72e7ca6b53c5332dac334b
diff --git a/dev-python/reportlab/reportlab-4.0.7.ebuild b/dev-python/reportlab/reportlab-4.0.7.ebuild
new file mode 100644
index 000000000000..0826a91d23ce
--- /dev/null
+++ b/dev-python/reportlab/reportlab-4.0.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+"
+SRC_URI+="
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_sphinx docs/source
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ cat > local-setup.cfg <<-EOF || die
+ [OPTIONS]
+ no-download-t1-files = 1
+ EOF
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py --post-install --verbosity=2 ||
+ die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}