summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:54:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:40 +0200
commitcf07b61e6c9310830b3aa531fdb243a980a10c91 (patch)
tree90d44247e43fd39870ade703a0ac410cfe1517fe
parentdev-python/pydyf: Bump to 0.10.0 (diff)
downloadgentoo-cf07b61e6c9310830b3aa531fdb243a980a10c91.tar.gz
gentoo-cf07b61e6c9310830b3aa531fdb243a980a10c91.tar.bz2
gentoo-cf07b61e6c9310830b3aa531fdb243a980a10c91.zip
dev-python/pyproject-hooks: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-hooks/Manifest1
-rw-r--r--dev-python/pyproject-hooks/metadata.xml2
-rw-r--r--dev-python/pyproject-hooks/pyproject-hooks-1.1.0.ebuild35
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pyproject-hooks/Manifest b/dev-python/pyproject-hooks/Manifest
index 62489d7f8552..473fd942c57d 100644
--- a/dev-python/pyproject-hooks/Manifest
+++ b/dev-python/pyproject-hooks/Manifest
@@ -1 +1,2 @@
DIST pyproject-hooks-1.0.0.gh.tar.gz 16001 BLAKE2B c90d2fb70ada9414cbbf201bfbb695b4e9055b61fdcdc8e0f8a2548e4f47e7512140fc71fee9f9306577d97b76ca64e77b7c58d526381c5481739e630e5250a1 SHA512 fca9b69859d7e3949b158c2879ba7ebc7305f1edaacdd84b71a92565010176d1194be03a21fd6b9aa65d175cfd8243ba3a50aab617fb56ceac6b263da6613e17
+DIST pyproject-hooks-1.1.0.gh.tar.gz 18774 BLAKE2B e6b376188655a5bc188567f412c22f8224209612c4fb0332f8c0c441180c18589139549139957834b3359bf3ced961e22f97e2449edc354047afaa6d2eff58d7 SHA512 256028d13adbe35126a63431a2a49e0c48adddce5ffc3ff2eebad368eee7ce52591ecfd8a8526876de20bc59dfc87156533d6a97b55538a739873e60f9509eff
diff --git a/dev-python/pyproject-hooks/metadata.xml b/dev-python/pyproject-hooks/metadata.xml
index 4788ace41f6a..c8e7d7283e51 100644
--- a/dev-python/pyproject-hooks/metadata.xml
+++ b/dev-python/pyproject-hooks/metadata.xml
@@ -6,7 +6,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">pyproject_hooks</remote-id>
+ <remote-id type="pypi">pyproject-hooks</remote-id>
<remote-id type="github">pypa/pyproject-hooks</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyproject-hooks/pyproject-hooks-1.1.0.ebuild b/dev-python/pyproject-hooks/pyproject-hooks-1.1.0.ebuild
new file mode 100644
index 000000000000..338edaf417b4
--- /dev/null
+++ b/dev-python/pyproject-hooks/pyproject-hooks-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrappers to build Python packages using PEP 517 hooks"
+HOMEPAGE="
+ https://pypi.org/project/pyproject-hooks/
+ https://github.com/pypa/pyproject-hooks/
+ https://pyproject-hooks.readthedocs.io/
+"
+SRC_URI="
+ https://github.com/pypa/pyproject-hooks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest