summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-11-30 18:08:08 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-11-30 18:09:47 -0600
commitcf17b4508a279d8babde83bcb2cf7765ac3dd14a (patch)
tree4309052ea9a39b8eeb7276b63994d3c422d613fe
parentnet-analyzer/nagios-plugins: new revision to trigger a rebuild. (diff)
downloadgentoo-cf17b450.tar.gz
gentoo-cf17b450.tar.bz2
gentoo-cf17b450.zip
dev-util/gitlab-runner: add 15.6.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.6.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index b14457ed8918..5e4d0b0ab54f 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-15.4.1-deps.tar.xz 138998168 BLAKE2B cee390b7955ee98eccffca6e
DIST gitlab-runner-15.4.1.tar.gz 1310885 BLAKE2B 9ba470444f7ba2db8be6044548dc9d7ee1ef8f50e63b0bc1ec2ba65ab9b5d035c5bc3a3bb50c4bf0d5acfa1329fe06fe9769f847aaa73c61ff116123f637e3f9 SHA512 1334c1d3fc830f49a0977cd43045105d013658361d55c807a99a2b36bd2b9dc4f3410185f13264a50a7cc13ab97d2191ec4a4daf45c10b24b42375dd6a2f6d13
DIST gitlab-runner-15.5.1-deps.tar.xz 151906516 BLAKE2B 50dced95fd72259d31d0dd6513ddc6aa1001c5ca83a1a7b33028a9bc163c553e2bcd80dff32443813bb85f8d215b8ae73c8f75f0cfedeb6062cd6824f0415f04 SHA512 a74673d48de86e337b936b60a35820621f35e6a70087ebf59a8641c6f3f1d5e1ba7d0e3156815d8204c3dbcd349f5e903be4501f566e419f5ca46382cebbf15f
DIST gitlab-runner-15.5.1.tar.gz 1327734 BLAKE2B 236d967a5ed18461d64429e078d3e40843e74aca96c23d572d070c13abf7ba3a3c7b4ba6046285d2aed261bdd2d9f5207f23a6b2c7c5cdc95c8cda5e0165f4c3 SHA512 c1ad7144bcea76b9ba20068bccc2b7a96240536cb0bdedcb0566674d05869c38f9052868314c3a58bddb1c6af304030fe0a2d055431d73eaff80ecb2226ea3e4
+DIST gitlab-runner-15.6.1-deps.tar.xz 160099188 BLAKE2B 3e8ab94a0af82e3354fd2ff59e313ffd1bbf761bdf9e800c588e54ad5c61b2ac4195d6e33f21d25c6b5c3f82e7385a8f30754b3c38899186a09868aca145b5f6 SHA512 69adf479c70fec6afea252cdaf6c393a7de3069360fcfdbf5c0da57f3ac31f51daf9af2c5d69bd615642c7d9684714aeb720f2e18559d112d30829abaf739a6d
+DIST gitlab-runner-15.6.1.tar.bz2 1235815 BLAKE2B 0b689878f49c4373ec9f895f6446d1f896c9f19f67ed306ab2b0ea08de34a9f70ff8547ec730061d9a997073c0b58a85e95e006481c9dab477cf4e5f4aa5f0d2 SHA512 f9580f5a0109ed7406bc33fd9c9936a4023761e790d9b1526a3a1d7037011ebdd8568837451708f0970d75d838f9a9462185542a57091637d1f61874310e8179
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.6.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.6.1.ebuild
new file mode 100644
index 000000000000..665cb1269501
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=133d7e76
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}