summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-11-27 11:27:24 +1100
committerJoonas Niilola <juippis@gentoo.org>2020-12-01 13:22:09 +0200
commitcf4b1ff64f961b0fd360e4f74351fa3325081890 (patch)
treec3dcd5bf38317a7335c2f1e9ef33e4e119e8035c
parentmedia-libs/osl: Version bump to 1.10.13 (diff)
downloadgentoo-cf4b1ff64f961b0fd360e4f74351fa3325081890.tar.gz
gentoo-cf4b1ff64f961b0fd360e4f74351fa3325081890.tar.bz2
gentoo-cf4b1ff64f961b0fd360e4f74351fa3325081890.zip
media-libs/osl: Version bump to 1.11.9.0
Version bump to 1.11.9.0, using LLVM 10 and C++14 using shared libraries to prevent compilation error New dependency on pybind11 added ENABLERTTI removed as flag removed upstream LLVM_ROOT set to prevent errors with pugixml Shader install patch replaced with setting OSL_SHADER_INSTALL_DIR and OSL_PTX_INSTALLDIR Thanks again to Luke A Guest, Sam James, Joonas Niilola, Reggie and mehw for contributions to this update. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Closes: https://bugs.gentoo.org/747475 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18418 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-libs/osl/Manifest1
-rw-r--r--media-libs/osl/osl-1.11.9.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/media-libs/osl/Manifest b/media-libs/osl/Manifest
index 9d9c3beb49e9..1b6d5ed44f26 100644
--- a/media-libs/osl/Manifest
+++ b/media-libs/osl/Manifest
@@ -1,2 +1,3 @@
DIST osl-1.10.10.tar.gz 13549066 BLAKE2B d91360d4cde0e8f70e01aa5cbf14bd6dc30be47ba96d4f2206adb75ef8f14af6af43b00f025cbf9b9c03cfcf117380ee9bb0a93129c314b249151cd97135757b SHA512 10371d9aefa786fefbae15cb9c71d7360bd903a36734840f7d0a960a615d48096b7170596bd934d10579b33d8f8398fc0e00471a10cd517c1a4a601169b2ca13
DIST osl-1.10.13.tar.gz 13551733 BLAKE2B 63b687ec46bd5334a7d0c00cfa5bf5243003e16adf2637fba648a75f98c10103c7c4b5fa1d091ab43b0929f85523b0fa79589eca56686490ee61c48069593767 SHA512 bc39fcf80878160807e35c52654a2993a7d33b3ab2fbf567ec50d0b23636a19064830afab5734f1e39276c77e843bbfe1d6b10a64fd4ebe69b17c8faa5378201
+DIST osl-1.11.9.0.tar.gz 14137334 BLAKE2B db68cb77d6af56e711b897371a4fe9386bf1a62625f9fa04012e9ec22346933fe3b0112301a8ad17ac6dd9c01c2a8e00c6d6e557d947870fd39bb3dec1443fd8 SHA512 f93bce0b29ff2da022372d81f2709c7db68e011c07c346b679c4b5ce05425f7eda8904779d7ea460817639e6be78a8c77272d71a3ffa8b068cfaab7572eb2e65
diff --git a/media-libs/osl/osl-1.11.9.0.ebuild b/media-libs/osl/osl-1.11.9.0.ebuild
new file mode 100644
index 000000000000..9ab4388c8dfd
--- /dev/null
+++ b/media-libs/osl/osl-1.11.9.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake llvm toolchain-funcs
+
+# check this on updates
+LLVM_MAX_SLOT=10
+
+DESCRIPTION="Advanced shading language for production GI renderers"
+HOMEPAGE="http://opensource.imageworks.com/?p=osl https://github.com/imageworks/OpenShadingLanguage"
+SRC_URI="https://github.com/imageworks/OpenShadingLanguage/archive/Release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/11"
+KEYWORDS="~amd64 ~x86"
+
+X86_CPU_FEATURES=(
+ sse2:sse2 sse3:sse3 ssse3:ssse3 sse4_1:sse4.1 sse4_2:sse4.2
+ avx:avx avx2:avx2 avx512f:avx512f f16c:f16c
+)
+CPU_FEATURES=( ${X86_CPU_FEATURES[@]/#/cpu_flags_x86_} )
+
+IUSE="doc partio qt5 test ${CPU_FEATURES[@]%:*}"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/pugixml
+ media-libs/openexr:=
+ media-libs/openimageio:=
+ <sys-devel/clang-11:=
+ sys-libs/zlib
+ partio? ( media-libs/partio )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/pybind11
+"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+PATCHES=()
+
+CMAKE_REMOVE_MODULES_LIST=()
+
+# Restricting tests as Make file handles them differently
+RESTRICT="test"
+
+S="${WORKDIR}/OpenShadingLanguage-Release-${PV}"
+
+llvm_check_deps() {
+ has_version -r "sys-devel/clang:${LLVM_SLOT}"
+}
+
+src_configure() {
+ local cpufeature
+ local mysimd=()
+ for cpufeature in "${CPU_FEATURES[@]}"; do
+ use "${cpufeature%:*}" && mysimd+=("${cpufeature#*:}")
+ done
+
+ # If no CPU SIMDs were used, completely disable them
+ [[ -z ${mysimd} ]] && mysimd=("0")
+
+ local gcc=$(tc-getCC)
+ # LLVM10+ needs CPP14+
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=14
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DINSTALL_DOCS=$(usex doc)
+ -DLLVM_STATIC=OFF
+ -DLLVM_ROOT="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
+ -DOSL_BUILD_TESTS=$(usex test)
+ -DOSL_SHADER_INSTALL_DIR="${EPREFIX}/usr/include/${PN^^}/shaders"
+ -DOSL_PTX_INSTALL_DIR="${EPREFIX}/usr/include/${PN^^}/ptx"
+ -DSTOP_ON_WARNING=OFF
+ -DUSE_PARTIO=$(usex partio)
+ -DUSE_QT=$(usex qt5)
+ -DUSE_SIMD="$(IFS=","; echo "${mysimd[*]}")"
+ )
+
+ cmake_src_configure
+}