summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-17 05:07:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-17 05:07:55 +0100
commitcf8aaf07cc3fcb2bd93c2d60f72758f14ef3170a (patch)
treec9bc84b320d181ef65269fc666786876b060d141
parentnet-misc/openssh: add 9.3_p1 (diff)
downloadgentoo-cf8aaf07cc3fcb2bd93c2d60f72758f14ef3170a.tar.gz
gentoo-cf8aaf07cc3fcb2bd93c2d60f72758f14ef3170a.tar.bz2
gentoo-cf8aaf07cc3fcb2bd93c2d60f72758f14ef3170a.zip
dev-python/botocore: Bump to 1.29.93
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.93.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3fa14db1bec9..83b5ffd8813c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,3 +9,4 @@ DIST botocore-1.29.89.gh.tar.gz 11227280 BLAKE2B 41a1243972e591ea23fb2eebaa5b5fb
DIST botocore-1.29.90.gh.tar.gz 11234660 BLAKE2B 9472b843e9a36b59ffb8171a5148d07736690fef62a88a1853011b0fc6cfabe8588ea1e48b66696f1f9a5ade17c53261349249d20b704d91c1b8e0aac3528b12 SHA512 cdf20dbdac7146f2fb19ac8adce2d4b6605241cbfcbf15b5df7d7b8ccf1cf95f04e683de8bfc71322f2bdc467a15ada3502b19c43f0e5d1bd5c1a07996a1e731
DIST botocore-1.29.91.gh.tar.gz 11238226 BLAKE2B b2bf854f37cc05f1c3bd873691bc0968f7bd2d7374479ce8b72ecbf168a7ba503b8e871212a8dd802e52a28f4913d70f2bfc42c19ebeff838466d7d5702640db SHA512 a1108a45f262716b955c7674e5098324727bcd17b130deed6cb7c88451a92f302272c55c767e7c1c6947be8f77eccece3eccc2ffb7d9da2f6649e21e87d9e5c6
DIST botocore-1.29.92.gh.tar.gz 11238265 BLAKE2B 42afd2517fe251ba5d7f0d948fb7892d90809cc289681f47bceab76b6a29b10425e7e7967e9c2b267166f6cae949dfd3f4ac98824b843ea23d37fd6ff6f363ca SHA512 eb8b7e6daa759fecf387b3ca04acb43aa11fb3a614edaed4d4e55361d2270220bb3c30f06fdc736a3ee57c52cf07afb97471221ab2a2c9205c3033969b7673a6
+DIST botocore-1.29.93.gh.tar.gz 11239506 BLAKE2B 7a05d5c611cbeda21e62abbbe13ab18cceae2d8b28136fc8669b09e3ebdcad5e5e352b32e807af7f2f038b6d045f82cf1a9cb3ec854f37db1f3204725fd8971e SHA512 df4ba05c28323321eae25412b97eb9f48978563aad5a0c166515bac3193b0404ebe111565be3b1e42ea47439f749e339ce11cc21736d5403ffbbe689f6fd8da8
diff --git a/dev-python/botocore/botocore-1.29.93.ebuild b/dev-python/botocore/botocore-1.29.93.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.93.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}