summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-24 09:48:05 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-24 09:51:11 -0500
commitcfae04837c12839f82daa604806e451dbc775427 (patch)
tree990d926d4c962fc65d20f1a67017b07c87f8a3e9
parentx11-misc/util-macros: Version bump to 1.19.3 (diff)
downloadgentoo-cfae04837c12839f82daa604806e451dbc775427.tar.gz
gentoo-cfae04837c12839f82daa604806e451dbc775427.tar.bz2
gentoo-cfae04837c12839f82daa604806e451dbc775427.zip
x11-libs/libXt: Version bump to 1.2.1
Closes: https://bugs.gentoo.org/766354 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libXt/Manifest1
-rw-r--r--x11-libs/libXt/libXt-1.2.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libXt/Manifest b/x11-libs/libXt/Manifest
index 10bc7df2fdb2..8ec0376e43e1 100644
--- a/x11-libs/libXt/Manifest
+++ b/x11-libs/libXt/Manifest
@@ -1 +1,2 @@
DIST libXt-1.2.0.tar.bz2 810521 BLAKE2B dc60b8fb126f465122eec4df287d5a0d12e483457ba20abbd04a17a8a5fb8a1073d8765236b8020353ec3c5f472b1580ba7a99d6896ce5fcdabaed5f4fbc6753 SHA512 06248508b6fe5dfba8ceb4518475f656162351d78136eeb5d65086d680dabe9aca7bba3c94347f9c13ef03f82dab3ac19d0952ee610bc8c51c14cee7cf65f0b1
+DIST libXt-1.2.1.tar.bz2 784610 BLAKE2B 69a1446a22acb50e625ab4a7b24b5db634d47a540d4543a3f58459dbb380d61aa4bbbde50328c76b2c31eaae3662a1c71cdbcf9bd3a0c915ae4e587f63fbee7a SHA512 6877af61ba91eeed6b6f80471b84f354ad0ec0827249c7ee0a00c13508063fe8d2696dd400a4bdbc6ca2ff67cbe1317ad5ac24522fd96099dc56535e33ca052c
diff --git a/x11-libs/libXt/libXt-1.2.1.ebuild b/x11-libs/libXt/libXt-1.2.1.ebuild
new file mode 100644
index 000000000000..72b65cdea0cb
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X Toolkit Intrinsics library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libSM-1.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( dev-libs/glib[${MULTILIB_USEDEP}] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable test unit-tests)
+ --without-fop
+ )
+}