summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 07:54:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 09:17:36 +0100
commitcfb09c817d18daa2530c608e81230425cad58a3f (patch)
tree2b02c8242a45e333981f2a7ee369ca486bfe931e
parentapp-emulation/virt-firmware: add openrc service script (diff)
downloadgentoo-cfb09c817d18daa2530c608e81230425cad58a3f.tar.gz
gentoo-cfb09c817d18daa2530c608e81230425cad58a3f.tar.bz2
gentoo-cfb09c817d18daa2530c608e81230425cad58a3f.zip
dev-python/nbformat: Bump to 5.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.10.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 1547499d24aa..a396ee68c876 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,2 +1,3 @@
DIST nbformat-5.10.2.tar.gz 142443 BLAKE2B 7089b27f2ed05e2240e12f583ed6d73aeace54939f235cdd41dede0f410a15927dd4223af0f9a8072bdaef15c3c737941c69313ee27abf69784df302677624b1 SHA512 a68e3261bd5a3126bb31a99fce3e85daad3651a39844f1fadf499c25af76b3b544188a7ece4d248534c4b3f3d3eca7a1caff17f0beaec9b866e989e76c666316
+DIST nbformat-5.10.3.tar.gz 142678 BLAKE2B 7de9dab29ca69fe89fb8c080f1e336a22acdc7d9a0daaf69dd03c61f7a01853895bd2302ee90787c3a7a555a27cf5cc1bab6ca0c898c60326ff3870820a00fbe SHA512 9baed15fed4bf05c2c97f7634ce1440149bf5e44a7fd330aa40f7c3954a6f16fc755e1d643a01a4d9ee62fb7a0f24299b83d9a4cf753e7c3495319ee052ae5e8
DIST nbformat-5.9.2.tar.gz 141264 BLAKE2B 71f5bb447d675b10276565cb53ac193963e5161fd27e925d639e7aa63f1e69db8903974d2f924ad5456940c4b904aba33d8ab10772fdb70e7e67974a90d1f3d6 SHA512 886a03cf95b39cdca48ae46d4946cee0f3dc1f5fa0e9dac7c6184b4c3e326adb739bd9da28032868a973577aa949feb5ae95a84017755948610ef7f208ebc5db
diff --git a/dev-python/nbformat/nbformat-5.10.3.ebuild b/dev-python/nbformat/nbformat-5.10.3.ebuild
new file mode 100644
index 000000000000..0bf953fb87b2
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.10.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)