summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-21 06:25:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-21 07:01:32 +0200
commitcfb9022d334b968ae2bd7231943224ebfd01cb54 (patch)
tree8fe8e95547b0c981a4fcf7437bcff2fbd2d9a123
parentdev-python/boto3: Bump to 1.24.13 (diff)
downloadgentoo-cfb9022d334b968ae2bd7231943224ebfd01cb54.tar.gz
gentoo-cfb9022d334b968ae2bd7231943224ebfd01cb54.tar.bz2
gentoo-cfb9022d334b968ae2bd7231943224ebfd01cb54.zip
app-admin/awscli: Bump to 1.25.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.13.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 638dc09fea88..63cee00150cd 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,2 +1,3 @@
DIST aws-cli-1.25.12.gh.tar.gz 2224456 BLAKE2B d6425983b09fc3942727108e188e184f48399388704ada03df1d65ddb9adffc9597a217b863766a862e96b59c03fdb3202e694289b54ee9298fe7e547639ecc3 SHA512 a77e0d082a8dacecadbd2fa6cc1143fa5148e075894565fe9a552e9d1a27fd068c72ae57eb5c628129bb024267111b76722cf2c40dc9f719db8d96232302b918
+DIST aws-cli-1.25.13.gh.tar.gz 2224352 BLAKE2B 0f6b94545f8504dcf6a458df28b39b3a909869033ccf04ad1ad3652e6606573002cbd3fed7f65756a140bac7d3b1ccddbc6fcc84391b194b3a987cf8534c4bdc SHA512 f494f9b31e91bb0e7446867efe4539f04ac91b12ad7f4db2f355d1a391ce7a8bd1d40f4afe04855d227414a7c2479ec6fdaf9a42f1959b28d205df48c2b4d723
DIST aws-cli-1.25.7.gh.tar.gz 2223153 BLAKE2B fcadda94fd721135f94b1538c4b27e41108064f6fd32f324d5436138e3d1b0ffcab53fcc545b01c461365d55c4bfa2a05d90e94c875c929a3227efae76452415 SHA512 194adacab0df87d8e4f0cdc71bb956bef6dc8b2de2e7e4416c9c079ff2b7c2bce7584ac1049428d0bcb134368b39c37c04bc5e6a8fc7540c44c64f3934ccaf21
diff --git a/app-admin/awscli/awscli-1.25.13.ebuild b/app-admin/awscli/awscli-1.25.13.ebuild
new file mode 100644
index 000000000000..4154af977ee6
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}