summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 22:03:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:20 +0000
commitcfb9e985b16af103b0995edfe6554cc53223cf50 (patch)
treed69af5044b9a6276edf988017151a01b50ca16b5
parentdev-haskell/wai: bump up to 3.2.1.1 (diff)
downloadgentoo-cfb9e985b16af103b0995edfe6554cc53223cf50.tar.gz
gentoo-cfb9e985b16af103b0995edfe6554cc53223cf50.tar.bz2
gentoo-cfb9e985b16af103b0995edfe6554cc53223cf50.zip
dev-haskell/edisonapi: new package, a depend of sci-mathematics/agda-2.5.2
A library of efficient, purely-functional data structures (API) Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-haskell/edisonapi/Manifest1
-rw-r--r--dev-haskell/edisonapi/edisonapi-1.3.1.ebuild31
-rw-r--r--dev-haskell/edisonapi/metadata.xml19
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/edisonapi/Manifest b/dev-haskell/edisonapi/Manifest
new file mode 100644
index 000000000000..0a901b67d4a4
--- /dev/null
+++ b/dev-haskell/edisonapi/Manifest
@@ -0,0 +1 @@
+DIST EdisonAPI-1.3.1.tar.gz 30512 SHA256 95a3b8d01599520a50456219b5a2e9f7832bcddaaeb8e94ce777bd87a4a6b56e SHA512 677161da64856421c834856ee2f5ef7f59880883433d5c5c4061f0ab2faa0cb39c4eb83061820b77dab852acc4cce5dc75740fe454b15dbc2e67e6e84510ce42 WHIRLPOOL f664631ce3d58fbc66c33b459291d3827f87f56a564c8dd1608487ee97bfc663ce566ad43776f4bf4aa40d04d2e6c2fe7aec7a6b5be9b9b33ccc496c54d0980d
diff --git a/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild b/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild
new file mode 100644
index 000000000000..c07857f83eb9
--- /dev/null
+++ b/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="EdisonAPI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library of efficient, purely-functional data structures (API)"
+HOMEPAGE="http://rwd.rdockins.name/edison/home/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/edisonapi/metadata.xml b/dev-haskell/edisonapi/metadata.xml
new file mode 100644
index 000000000000..dac5f3d4c343
--- /dev/null
+++ b/dev-haskell/edisonapi/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Edison is a library of purely functional data structures written by
+ Chris Okasaki. It is named after Thomas Alva Edison and for the
+ mnemonic value EDiSon (Efficent Data Structures).
+ Edison provides several families of abstractions, each with
+ multiple implementations. The main abstractions provided by Edison are:
+ Sequences such as stacks, queues, and dequeues;
+ Collections such as sets, bags and heaps; and
+ Associative Collections such as finite maps and priority queues
+ where the priority and element are distinct.
+ </longdescription>
+</pkgmetadata>