summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-10-21 05:07:07 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-21 14:50:10 -0500
commitcfc0221a1c5b43122e586584a1814ae8cd7ea424 (patch)
treec8c7aaa100af92aef3a1d193621a73ab97b77436
parentsys-apps/portage: fixup 2.3.78 GetConfigTestCase (diff)
downloadgentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.tar.gz
gentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.tar.bz2
gentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.zip
dev-python/python-augeas: bump to 1.0.3
Closes: https://bugs.gentoo.org/678946 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/python-augeas/Manifest1
-rw-r--r--dev-python/python-augeas/metadata.xml1
-rw-r--r--dev-python/python-augeas/python-augeas-1.0.3.ebuild25
3 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-augeas/Manifest b/dev-python/python-augeas/Manifest
index 25b379090ebc..902f2d87a6dc 100644
--- a/dev-python/python-augeas/Manifest
+++ b/dev-python/python-augeas/Manifest
@@ -1,3 +1,4 @@
DIST python-augeas-0.4.1.tar.gz 89652 BLAKE2B 571c67fd6f10b209578eed7b3a7a1d628b8a23fa0cea81f3f6569031a36ce08536a03b714f13c0c3cc8fbe2727ff385b88eff81d498700ea6ba9197b4e31bf01 SHA512 ccd6ea10f927f06eba74dd48c21c7ca9a99c2910741ef925f078c09cd8a3421e63de3b74df2903a2cfd17f3defaa8df4624c9743d20e13bb5bfeacd7d50c5938
DIST python-augeas-0.4.2_pre131218.tar.xz 77636 BLAKE2B 033063d449b4c5ec2daa7a6266a4cf378be1964509c77d0d02274b7e70c70d245db5139dad582510aa2cf71e12d43d258855d45f8137e1bf843a99f79af3f8a7 SHA512 3677dfa4d7b6bbb22009ebee4ed4b46e50f7e5712354f5061476d5d21c86b956c4408f5ca005b674ad0e14e26c970830572aa077af6bb594dbff116991676e86
DIST python-augeas-0.5.0.tar.gz 90667 BLAKE2B 5d563350c3f80db45aad87326c445e93e3563ca6eb8de17889cdc91735c61dfcf0fda4e93f15c0d450ee156d57cb71598f32cdce6f6716b0fd610b793f103641 SHA512 d93d9e21c720084ee3c1841a2172dd1a4cfb41e668de0f557bd214efd65e685a1e5fc713a7d34e0fed727fe908bb1e8a09a1c10587bc27f3708cbcdee575cc51
+DIST python-augeas-1.0.3.tar.gz 92747 BLAKE2B 0dda6ae6bbac1689c633301b91877cca4cf20773a3bf83bfd8a809dfc973da011cbeb39ed12f34b67f8f1be50ce5b9fc89e9cc7abbc992117853c11851b18fab SHA512 737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa
diff --git a/dev-python/python-augeas/metadata.xml b/dev-python/python-augeas/metadata.xml
index cdd8abd046a2..08cc0a07f306 100644
--- a/dev-python/python-augeas/metadata.xml
+++ b/dev-python/python-augeas/metadata.xml
@@ -9,5 +9,6 @@ python-augeas is a set of Python bindings around augeas.
</longdescription>
<upstream>
<remote-id type="pypi">python-augeas</remote-id>
+ <remote-id type="github">hercules-team/python-augeas</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-augeas/python-augeas-1.0.3.ebuild b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
new file mode 100644
index 000000000000..10b466c7506f
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd test && "${PYTHON}" test_augeas.py || die
+}