summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-05-07 10:22:04 +0200
committerUlrich Müller <ulm@gentoo.org>2021-05-07 10:24:16 +0200
commitcfc8a29dba62ec02fec805037a112355608a9511 (patch)
tree015c00c72287feeb9b2a04d5e5516376067fb0a8
parentdev-python/pytest-mock: Bump to 3.6.1 (diff)
downloadgentoo-cfc8a29d.tar.gz
gentoo-cfc8a29d.tar.bz2
gentoo-cfc8a29d.zip
media-gfx/brscan4: Initial import
From my developer overlay. Ebuild contributed by me. Suggested-by: Matt Turner <mattst88@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--media-gfx/brscan4/Manifest2
-rw-r--r--media-gfx/brscan4/brscan4-0.4.10.1.ebuild68
-rw-r--r--media-gfx/brscan4/metadata.xml10
3 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/brscan4/Manifest b/media-gfx/brscan4/Manifest
new file mode 100644
index 000000000000..04480576375d
--- /dev/null
+++ b/media-gfx/brscan4/Manifest
@@ -0,0 +1,2 @@
+DIST brscan4-0.4.10-1.i386.rpm 100151 BLAKE2B 94fd7daa5682b294740a6e1345c4ab8d488589896c3fa34eafc131b1cdc2ef2e022e11795ebc261538c6107583602a9622946ea049a3cfbbeb547e7e9c8825ad SHA512 5daeb9a1304f3aeb0a2e17823887a546ff872dfb42bf08ab403539815553da597504ac7afcbb2a34fbcfd8d973c03c8ca2c62617f8c499b9fc44b1719e4f2611
+DIST brscan4-0.4.10-1.x86_64.rpm 118863 BLAKE2B 1e518122b049a6cd594e4603311d37f289aef4ad3973cbe846700c2a5c0c8f0ec994f6608817a1c12d6494c3ae78178b43f4ba8450ab00153e27f533ec1957c8 SHA512 c648db8d8543dec9e1cd556f2e0415c170c06935febd1373d783191b159ed9ed67043644ef81fb18027de89270e10a5cedcee11ea66ee262df1a2d4f006e4875
diff --git a/media-gfx/brscan4/brscan4-0.4.10.1.ebuild b/media-gfx/brscan4/brscan4-0.4.10.1.ebuild
new file mode 100644
index 000000000000..93254dfefc8b
--- /dev/null
+++ b/media-gfx/brscan4/brscan4-0.4.10.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eapi8-dosym readme.gentoo-r1 rpm
+
+MY_P="${PN}-${PV%.*}-${PV##*.}"
+DESCRIPTION="Brother scanner driver"
+HOMEPAGE="https://www.brother.com/"
+SRC_URI="
+ amd64? ( https://download.brother.com/welcome/dlf105203/${MY_P}.x86_64.rpm )
+ x86? ( https://download.brother.com/welcome/dlf105202/${MY_P}.i386.rpm )"
+S="${WORKDIR}/opt/brother/scanner/${PN}"
+
+LICENSE="Brother"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="zeroconf"
+RESTRICT="strip"
+
+RDEPEND="media-gfx/sane-backends
+ virtual/libusb:0
+ zeroconf? ( net-dns/avahi )"
+
+src_install() {
+ local dest=/opt/brother/scanner/${PN}
+ local lib=$(get_libdir)
+
+ insinto /etc${dest}
+ doins Brsane4.ini brsanenetdevice4.cfg
+ doins -r models4
+ dosym8 -r {/etc,}${dest}/Brsane4.ini
+ dosym8 -r {/etc,}${dest}/brsanenetdevice4.cfg
+ dosym8 -r {/etc,}${dest}/models4
+
+ exeinto ${dest}
+ doexe brsaneconfig4
+ dosym8 -r {${dest},/usr/bin}/brsaneconfig4
+
+ if use zeroconf; then
+ doexe brscan_cnetconfig
+ # Don't install brscan_gnetconfig because it depends on gtk+:2
+ fi
+
+ into ${dest}
+ dolib.so "${WORKDIR}"/usr/${lib}/sane/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so
+ dosym8 -r {${dest}/${lib},/usr/${lib}/sane}/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so
+
+ insinto /etc/sane.d/dll.d
+ newins - ${PN} <<< "brother4"
+
+ local DOC_CONTENTS="If want to use a remote scanner over the network,
+ you will have to add it with \"brsaneconfig4\"."
+ use zeroconf || DOC_CONTENTS+="\\n\\nNote that querying the network
+ (\"brsaneconfig4 -q\") will not work unless you emerge ${PN} with
+ the zeroconf flag enabled."
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/media-gfx/brscan4/metadata.xml b/media-gfx/brscan4/metadata.xml
new file mode 100644
index 000000000000..5bd0c1a7db5c
--- /dev/null
+++ b/media-gfx/brscan4/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+</maintainer>
+</pkgmetadata>