summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-28 00:03:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-28 08:13:33 +0100
commitcfcfb63e2cd63157934eda5575d559ebd547aa36 (patch)
treee4c452a458efa098df4ad652e977524383660f99
parentdev-python/importlib_resources: Remove old (diff)
downloadgentoo-cfcfb63e.tar.gz
gentoo-cfcfb63e.tar.bz2
gentoo-cfcfb63e.zip
dev-db/sqliteman: EAPI-8 bump, switch to cmake.eclass, xdg.eclass
Cleanup obsolete minimum version deps Fix pixmap icon installation path for use with desktop file Improve desktop file (patch thx to Fedora) Bug: https://bugs.gentoo.org/834312 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-cmake.patch10
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-desktop.patch11
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r5.ebuild38
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-cmake.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-cmake.patch
new file mode 100644
index 000000000000..99c3b080ea0d
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-cmake.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -154,6 +154,6 @@
+ )
+ INSTALL(FILES
+ sqliteman/icons/sqliteman.png
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/icons/hicolor"
++ DESTINATION "${CMAKE_INSTALL_PREFIX}/share/pixmaps"
+ )
+ ENDIF (WIN32)
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-desktop.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-desktop.patch
new file mode 100644
index 000000000000..f6d765e40a45
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-desktop.patch
@@ -0,0 +1,11 @@
+--- a/sqliteman.desktop
++++ b/sqliteman.desktop
+@@ -8,7 +8,7 @@
+ Terminal=false
+ StartupNotify=true
+ MimeType=application/x-sqlite3;
+-
++Categories=Development;Database;
+ # Translations
+ GenericName[cs]=Sqlite administrace
+
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r5.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r5.ebuild
new file mode 100644
index 000000000000..65f52a34916f
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="https://sourceforge.net/projects/sqliteman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ >=x11-libs/qscintilla-2.10.3:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-lpthread.patch"
+ "${FILESDIR}/${P}-qt5.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-desktop.patch"
+)
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf ${PN}/qscintilla2 || die
+
+ append-flags -fPIC
+ cmake_src_prepare
+}